Opened 9 years ago

Closed 9 years ago

#1906 closed defect (fixed)

Browsing some ways resulting in server error 500

Reported by: Michi Owned by: tom@…
Priority: major Milestone:
Component: website Version:
Keywords: Cc:

Description

Browsing some ways via the website does not work: The server responds with a server error 500:

"Application error

The OpenStreetMap server encountered an unexpected condition that prevented it from fulfilling the request (HTTP 500)

Feel free to contact the OpenStreetMap community if your problem persists. Make a note of the exact URL / post data of your request."

Example ways:

35380132
31654429
31654431

Attachments (1)

packet (830 bytes) - added by Michi 9 years ago.
TCP stream capture

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by tom@…

  • Resolution set to worksforme
  • Status changed from new to closed

All those URLs work fine for me.

comment:2 Changed 9 years ago by Michi

  • Resolution worksforme deleted
  • Status changed from closed to reopened

WTF?

How can I prove it?

Try this URL.

Changed 9 years ago by Michi

TCP stream capture

comment:3 Changed 9 years ago by tom@…

I suspect the problem is related to the German translations in some way - in other words it only happens if the page is being rendered in German.

comment:4 Changed 9 years ago by tom@…

  • Priority changed from major to minor

comment:5 Changed 9 years ago by Michi

Yeah, I can confirm this. Setting 'en' as the prefered language, the server returns the correct page.

comment:6 Changed 9 years ago by tomhughes

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [15559]) Revert to using join instead of to_sentence for now as to_sentence is
broken in rails 2.2 when I18N is in use. We can go back to using
to_sentence once we have gone to rails 2.3 which fixes the problem.

Close #1906.

comment:7 Changed 9 years ago by vgeorge

  • Priority changed from minor to major
  • Resolution fixed deleted
  • Status changed from closed to reopened

This message apear when I try to access the following pages:

http://www.openstreetmap.org/user/vgeorge
http://www.openstreetmap.org/diary

My browser is in pt-br and my profile is configured to use this language.

comment:8 Changed 9 years ago by tom@…

  • Resolution set to fixed
  • Status changed from reopened to closed

The cause will be different however, so please enter a new bug don't just reopen some other bug that happens to have the same symptom (a 500 error is a pretty standard error for any server bug).

Note: See TracTickets for help on using tickets.