Opened 10 years ago

Closed 10 years ago

#1927 closed defect (fixed)

rss method in changeset controller is a duplicate of the list_user method: How is method aliasing done in Ruby/Rails?

Reported by: avar Owned by: Tom Hughes
Priority: minor Milestone:
Component: website Version:
Keywords: ruby, rails Cc:

Description

Changeset [15716] introduced user RSS support, but also some duplicated code because I don't know how to do method aliasing in Ruby/Rails?.

Change History (3)

comment:1 Changed 10 years ago by avar

(In [15718]) Add RSS feed for global recent changes & changes within a bbox. Solves #1737

This has so much copy/paste code it hurts, the new list*_rss methods are just copies of the old list* methods, but see #1927 for that.

comment:2 Changed 10 years ago by avar

Also [15718], evil copy/paste coding.

comment:3 Changed 10 years ago by avar

Resolution: fixed
Status: newclosed

Solved with rails magic!

Note: See TracTickets for help on using tickets.