Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1950 closed defect (invalid)

Wrong "Last rendered" time and date

Reported by: rune.andersen@… Owned by: steve8@…
Priority: trivial Milestone:
Component: mapnik Version:
Keywords: status lastrendered url Cc:

Description

When checking certain tiles by appending /status to the tile URL, Mapnik reports: Tile is due to be rendered. Last rendered at Sat Jan 01 00:00:00 2000

This is not correct in my case, since none of the ways rendered in the tile existed in 2000. Besides, the date 00.00.00 00:00:00 is obviously an error.

Example (not working when posting this): http://tile.openstreetmap.org/18/138654/70925.png/status

Change History (3)

comment:1 Changed 10 years ago by Shaun McDonald

You example now has: Tile is clean. Last rendered at Thu Jun 11 22:20:23 2009

The reason for that date, is that the tile in question is due to be re-rendered, and the way that we currently denote this is by setting the last rendered date to a long time ago.

comment:2 Changed 10 years ago by Ldp

Resolution: invalid
Status: newclosed

As above: not a mapnik issue, and by design.

comment:3 Changed 10 years ago by Vid the Kid

This is probably the first time I've seen January 1, 2000 used as a placeholder for "a long time ago" in computing. Usually it's 1900 or the Unix Epoch.

Makes me wonder how many programmers are enjoying the "fact" that year-2100 compliance is a far-off concern...

Note: See TracTickets for help on using tickets.