Opened 10 years ago

Closed 5 years ago

#1971 closed defect (invalid)

[roads] bad mapnik layering for highway=pedestrian + area=yes

Reported by: tux@… Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

Ways tagged with highway=pedestrian + area=yes (i.e. a square) are rendered "on top" of everything else, even if these things are layered on top of the square with layer=1.

Look at this example:

Mapnik: http://www.openstreetmap.org/?lat=50.08783&lon=14.40437&zoom=18&layers=B000FTF

Osmarender: http://www.openstreetmap.org/?lat=50.08783&lon=14.40437&zoom=17&layers=0B00FTF

Error is with square "Malostranské náměstí", there are few buildings in center of the square and some parking places. Osmarender got it right. Mapnik got it wrong.

Change History (9)

comment:1 Changed 10 years ago by Cobra

This happens also with other ways tagged highway=* and buildings. Even ways with layer=-1 (and tunnel=yes) are rendered above buildings with layer=1... Only one thing works again: building=yes|amenity=place_of_worship which is now rendered again on top of highway=pedestrian|area=yes.

I understand that those ways should be visible even when there is a building "over" them so you can still see there are some ways but in my opinion the current style results in an awkward look at quite a few places. Would it be possible to add some (pseudo-)transparency here (e.g. render the building with ~50% transparency above the way/area) so you can see that there is a building above the way but the way is still visible?

comment:2 Changed 10 years ago by Cobra

"Only one thing works again: building=yes|amenity=place_of_worship which is now rendered again on top of highway=pedestrian|area=yes." when I wrote this, I didn't notice someone had made a multipolygon there, so forget about that.

comment:3 Changed 9 years ago by steve8@…

Owner: changed from steve8@… to mapnik-team@…

comment:4 Changed 9 years ago by MarsmanRom

ja, the problem really sucks. tried to get around it with 'multipolygon outer / inner', but for some reason even this doesnt work. layers are completely ignored. 2 buildings and a construction site are not being shown, just the square 'on top' of it: http://www.openstreetmap.org/?lat=52.431441&lon=13.532622&zoom=18

comment:5 Changed 9 years ago by wicking

this is a duplicate of #1873. Am I right? Or is the other one a duplicate of this one (here is more information)? ;-)

comment:6 Changed 9 years ago by BiIbo

I think both of these tickets are the same issue, so perhaps close one of these two as duplicate of the other.

comment:7 Changed 9 years ago by Emilien

Encountered the same bug with a building hidden behind an area. Reported it in the forums [1], and using a multipolygon got the rendering right. More info in the forums.

[1] http://forum.openstreetmap.org/viewtopic.php?id=7590

comment:8 Changed 5 years ago by math1985

Summary: bad mapnik layering for highway=pedestrian + area=yes[roads] bad mapnik layering for highway=pedestrian + area=yes

comment:9 Changed 5 years ago by math1985

Resolution: invalid
Status: newclosed

This is a tagging error, as the buildings in the middle are not part of the square. See http://forum.openstreetmap.org/viewtopic.php?id=7590 for more information. I will therefore close this issue as invalid.

Note: See TracTickets for help on using tickets.