Opened 10 years ago

Closed 10 years ago

#2000 closed defect (fixed)

Can't select version for reverting a way

Reported by: matti@… Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

using Seamonkey 1.9.1 branch build (the same Gecko version is used by Firefox 3.5) and Shockwave Flash 10.0 r22 on windows 2003 or IE6 with the same Flash version only as ActiveX Plugin and a display resolution 1280x1024

Steps to reproduce:

  1. load http://www.openstreetmap.org/edit?lat=48.74607&lon=9.50743&zoom=17

(I hope the way is still in this area if we get it reverted with other tools)

  1. select the boundary way with ID 29412601
  2. Press h for history
  3. in the history dialog open the dropdown list for selecting the revision to restore

5: You can not select an entry in the list for restoring, could be that the history list is too long ( I need the version from the 4th june)

Change History (3)

comment:1 in reply to:  description Changed 10 years ago by matti@…

Replying to matti@mversen.de:

using Seamonkey 1.9.1 branch build (the same Gecko version is used by Firefox 3.5) and Shockwave Flash 10.0 r22 on windows 2003 or IE6 with the same Flash version only as ActiveX Plugin and a display resolution 1280x1024

Steps to reproduce:

  1. load http://www.openstreetmap.org/edit?lat=48.74607&lon=9.50743&zoom=17

(I hope the way is still in this area if we get it reverted with other tools)

  1. select the boundary way with ID 29412601
  2. Press h for history
  3. in the history dialog open the dropdown list for selecting the revision to restore

5: You can not select an entry in the list for restoring, could be that the history list is too long ( I need the version from the 4th june)

edit Confirmed, the issue is caused by a list that is larger than the screen, works with a hack: http://omploader.org/vMXc2Mg

comment:2 Changed 10 years ago by Richard

Summary: Can select Version for reverting a WayCan't select version for reverting a way

This appears to be an issue with Postgres date handling - it doesn't round in the same way that MySQL does, leading to ridiculously long dates. Will look into it.

comment:3 Changed 10 years ago by Richard

Resolution: fixed
Status: newclosed

Will be fixed in next release.

Note: See TracTickets for help on using tickets.