Opened 10 years ago

Closed 10 years ago

#2071 closed defect (fixed)

Potlatch 1.1a shows me Potlatch in Italian but my UI language in rails is "is,en"

Reported by: avar Owned by: Tom Hughes
Priority: critical Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

This is odd.

Change History (5)

comment:1 Changed 10 years ago by Tom Hughes

Owner: changed from richard@… to Tom Hughes

comment:2 Changed 10 years ago by Tom Hughes

I can't reproduce this - I've set my preferred language to is,en-GB,en and I'm getting English not Italian.

comment:3 in reply to:  2 Changed 10 years ago by avar

Replying to TomH:

I can't reproduce this - I've set my preferred language to is,en-GB,en and I'm getting English not Italian.

It happens intermittently. I refreshed the main site around 15 times always getting "Welcome to OpenStreetMap" (railsport has no Icelandic translation) before getting "Wilkommen bei OpenStreetMap" (German).

I haven't been able to reproduce it locally though, so it might be some sort of caching issue on the main site, or I haven't pounded F5 hard enough.

comment:4 Changed 10 years ago by Richard

I've had German on mine too (lolcat, en).

comment:5 Changed 10 years ago by tomhughes

Resolution: fixed
Status: newclosed

(In [16548]) Don't use the (unset) value of I18n.locale to try and select a language as the one we want is in lang so just use that. Fixes #2071.

Note: See TracTickets for help on using tickets.