Opened 10 years ago

Closed 10 years ago

#2088 closed defect (invalid)

Accept Header detection needs improvement

Reported by: matti@… Owned by: Tom Hughes
Priority: major Milestone:
Component: website Version:
Keywords: Cc:

Description

The accept header parsing seems to be a little bit broken. The website falls back to english with this headers :

de-at de;q=0.8 en-us;q=0.5 en;q=0.3

or it also fails back to english with: de de-de;q=0.8 en-us;q=0.5 en;q=0.3

it works (german website displayed) with :

de-de de;q=0.8 en-us;q=0.5 en;q=0.3

Change History (2)

comment:1 Changed 10 years ago by Tom Hughes

This is when you're not logged in I assume (when you are logged in the HTTP headers are ignored in favour of your user preferences)?

Is your browser really space separating the languages? All the ones I've seen use a comma...

comment:2 Changed 10 years ago by matti@…

Resolution: invalid
Status: newclosed

My issue is caused by my settings, i should have known it better, sorry ! Sorry also for the bad bug report, my used Browser is Seamonkey trunk from today (Gecko based) on win32. The space is just from the website : http://browserspy.dk/accept.php that i used for see the send accept header, the real header looks like this: Accept-Language: de,en;q=0.7,en-us;q=0.3[CRLF] (using http://web-sniffer.net )

I never touched my language field in my settings, i had this fields stored: "de-DE,en-US,en,de" and that result is english while "de,de-DE,en-US,en" and "de-DE,deen-US,en" works and I get german.

marking invalid

Note: See TracTickets for help on using tickets.