Opened 10 years ago

Closed 2 years ago

#2100 closed enhancement (fixed)

cycleway:left=track not rendered

Reported by: ChrisB Owned by: Andy Allan
Priority: minor Milestone:
Component: opencyclemap Version:
Keywords: Cc: T, M, G, AsgerFrank

Description

(I do not see a component to file bugs for the Cycle Map? So I am filing in osmarender, might be wrong place.. please change to correct component if so.)

here is a cyclepath next to the road using the key:value notation (cycleway:left,track). This doesn't appear to be rendered on the cycle map.

Change History (8)

comment:1 Changed 10 years ago by osm@…

I can't find a better component so I'll leave the bug open. But I won't fix it either. *g*

comment:2 Changed 10 years ago by Andy Allan

Component: osmarenderopencyclemap
Owner: changed from osm@… to Andy Allan
Status: newassigned

comment:3 Changed 10 years ago by ChrisB

This is probably a dupe of #2195, assuming that once Mapnik renders cycleway=track then so will opencyclemap?

comment:4 Changed 10 years ago by Andy Allan

Summary: cycleway by road not renderedcycleway:left=track not rendered

Nope, there's no link in the rendering rules between the "mapnik" layer and opencyclemap.

comment:5 Changed 10 years ago by Andy Allan

Priority: majorminor
Type: defectenhancement

comment:6 Changed 4 years ago by T M G

Cc: T M G added

comment:7 Changed 4 years ago by T M G

According to Taginfo, this affects about 8% of all ways tagged with "cycleway". I'd consider not rendering 8% of the cycleways a problem more serious than "minor".

comment:8 Changed 2 years ago by AsgerFrank

Cc: AsgerFrank added
Resolution: fixed
Status: assignedclosed

I've also considered this issue more than a minor problem. However, I have recently learned that Andy Allan has fixed the issue, and I can confirm that! https://twitter.com/gravitystorm/status/778319384578318336

Note: See TracTickets for help on using tickets.