Ticket #2109 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Upload does not recognize all changes

Reported by: BearT Owned by: cbro@…
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

My installation of M. (Ubuntu 9.04 64bit r16708) just had some internal states mixed up. The menu item File > Upload was either greyed out or (when pressing Ctrl+U) the list of the changes was empty. But when I tried to close M. I was warned that there were unsaved changes. When I tried to upload those changes the list of changes was empty again. At least the "Dirty Layer" wasn't and so I worked around this bug by changing all items in the dirty layer again. Afterwards the upload just worked fine.

It's quite hard (read: impossible) for me to reproduce this bug, but I think the list of changes for uploading and the dirty layer should somehow be connected to prevent such weird behaviour.

Change History

comment:1 Changed 5 years ago by Koying

It is probably due to an object staying in the "dirty" layer when it shouldn't.

To solve this, I have to find out why and so, have to know what actions you did before trying to upload.

If you have such an occurrence again, please save the session as an .MDC document and attach.

comment:2 Changed 4 years ago by Koying

  • Status changed from new to closed
  • Resolution set to fixed

Assumed fixed

Note: See TracTickets for help on using tickets.