Opened 9 years ago

Closed 7 years ago

#2121 closed defect (wontfix)

Error 500; TypeError: wrong argument type nil uploading changeset

Reported by: MikeN Owned by: TomH
Priority: minor Milestone: OSM 0.6
Component: api Version:
Keywords: bulk_upload TypeError Cc: Edgemaster

Description

Using the bulk_upload.py from
http://svn.openstreetmap.org/applications/utils/import/bulk_upload_06/bulk_upload.py ,
dated about 1 week ago, I get an upload error:

Uploading to changeset:1990229
Error uploading changeset:500
TypeError?: wrong argument type nil (expected String)

This error occurred at 31 July 2009 01:45:52 GMT. It is hoped that the details of the traceback error from the logs can be analyzed to determine the cause. The upload account for this data was 'MikeNBulk'. As a double check, there was a second attempt today at approximately 01 Aug 2009 18:05:00 GMT which also failed.

The first 13,000 nodes from the file went into changeset 1989960. The failed session was captured in a network trace and inspected for correct syntax.

As a test, the rest of the file has been uploaded to api06.dev.openstreetmap.org , but no errors were generated.

For reference if necessary, a zip file has been attached with the following data:

waterbody.1.osm - the source data for upload
waterbody.1.osm.db - the nodes from the upload which have already been uploaded successfully and assigned.
OSM_TransactionChangesetPost_Wireshark.xml - the XML of the changeset that consistently produces the error, as extracted from the full Wireshark capture.
Uploadcapture_Wireshark.cap - the complete Wirehsark capture of the failed upload session.
bulk_upload.py - the version of bulk_upload used

Attachments (1)

uploadError500.zip (45.3 KB) - added by MikeN 9 years ago.
Files with details about upload error

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by MikeN

Files with details about upload error

comment:1 Changed 9 years ago by MikeN

Update - the full data file is too large for an attachment, but is available at http://home.att.net/~niceman/uploadProblem.zip

comment:2 Changed 9 years ago by Edgemaster

  • Cc Edgemaster added

Just for the record, I tried to debug this issue on the mailing lists, couldn't reproduce the error on the dev server. Couldn't see anything untoward in the capture of the uploaded osc file.

comment:3 Changed 9 years ago by MikeN

I am also willing to start the troubleshooting from the code to try to isolate this if I can get the traceback error from the server.

comment:4 Changed 9 years ago by MikeN

  • Priority changed from major to minor

I have discovered a workaround - I was able to reduce the diff set size from 1000 to 500, and that change allowed the rest of the data to upload.

I'm still willing to look at the code because there's probably still some border condition hiding inside, but I have a workaround to allow uploading to continue.

comment:5 Changed 7 years ago by TomH

  • Resolution set to wontfix
  • Status changed from new to closed

I'm going to close this as it seems nobody looked at the server logs at the time and they will be long gone now so there is no way to debug this.

Note: See TracTickets for help on using tickets.