Opened 10 years ago

Closed 10 years ago

#2124 closed defect (wontfix)

"browse" for very long ways gives HTTP 500 Application error

Reported by: Ldp Owned by: Tom Hughes
Priority: minor Milestone:
Component: website Version:
Keywords: Cc:

Description

There are still a few very long ways in the database, and when trying to view them with http://www.openstreetmap.org/browse/way/ you get a HTTP 500 Application error.

A few examples, valid until these have been fixed:

http://www.openstreetmap.org/browse/way/31312200 http://www.openstreetmap.org/browse/way/32240204 http://www.openstreetmap.org/browse/way/33195250

I suggest, when the api browser is hitting limits, to at least exit more gracefully, and if possible, give a hint about the long way being the cause.

Change History (2)

comment:1 Changed 10 years ago by Ldp

To be fair: the long ways this breaks on are no longer in the database, and will never return as long as there is a 2000 node limit on ways.

For the record, browse does work for a 11406 node way, which was, until a minute ago, the longest way in the db.

comment:2 Changed 10 years ago by Tom Hughes

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.