Opened 8 years ago

Closed 8 years ago

#2128 closed defect (fixed)

Render state names and state abbr. and render capital cities before other cities.

Reported by: delta_foxtrot2 Owned by: steve8@…
Priority: major Milestone: Wishlist
Component: mapnik Version:
Keywords: Cc: delta_foxtrot@…

Description

Render state names and state abbr. and render capital cities before other cities.

Attachments (1)

osm.xml.patch (3.6 KB) - added by delta_foxtrot2 8 years ago.
osm.xml patch

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by delta_foxtrot2

osm.xml patch

comment:1 follow-up: Changed 8 years ago by Ldp

Capitals before others is now in svn r16950.

Did you test the states rendering? Not every US state has a ref=*, and the place=state nodes are not centered on the state, but rather seem to be placed somewhere far southwest in the state extent.

The patch would also break country rendering, in the sense that it would not render the country names past z3, instead of until z6.

comment:2 in reply to: ↑ 1 Changed 8 years ago by delta_foxtrot2

Replying to Ldp:

Did you test the states rendering? Not every US state has a ref=*, and the place=state nodes are not centered on the state, but rather seem to be placed somewhere far southwest in the state extent.

The US isn't the only place in the world with states. I've tested it against Australia and that is how most Australian maps look. If there is problems with the US and other data people will quickly see the mistake and fix it. Just like they are with TIGER data.

The patch would also break country rendering, in the sense that it would not render the country names past z3, instead of until z6.

The problem is, Europe approx. the same land area as bigger countries like Australia, Canada and the US. Instead of states Europe has countries, this could be dealt with by using boundaries so countries with larger land masses show the states and smaller countries show the country name.

comment:3 Changed 8 years ago by ldp

  • Resolution set to fixed
  • Status changed from new to closed

(In [17070]) Show state abbr/names (patch by delta_foxtrot2). Fixes #2128. Lvl 4 boundaries in sooner.

Note: See TracTickets for help on using tickets.