Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2129 closed enhancement (fixed)

Mapnik: render icons on polygon POIs

Reported by: skunk Owned by: mapnik-team@…
Priority: trivial Milestone:
Component: mapnik Version:
Keywords: poi polygon icon Cc: fiveisalive

Description

Currently no icons are rendered on POIs which are entered as polygons, though they might get a different color, therefore many mappers enter a polygon AND a node, which should not happen (according to http://wiki.openstreetmap.org/wiki/Good_practice).

This is a patch to render icons and texts on polygons as well.

Attachments (1)

osm-template.xml.diff (3.1 KB) - added by skunk 10 years ago.
this is a diff for /applications/rendering/mapnik/osm-template.xml

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by skunk

Attachment: osm-template.xml.diff added

this is a diff for /applications/rendering/mapnik/osm-template.xml

comment:1 Changed 10 years ago by Ldp

Slightly cleaned up, now in r16952

comment:2 Changed 10 years ago by Ldp

Owner: changed from steve8@… to mapnik-team@…

comment:3 Changed 10 years ago by Ldp

Resolution: fixed
Status: newclosed

It's now rendering. Thanks for the patch!

comment:4 Changed 10 years ago by fiveisalive

Resolution: fixed
Status: closedreopened

When this went live, it correctly rendered names as well as icons on polygon ways, such as libraries or churches, e.g.

Robbins Library in Arlington, MA, USA:

http://www.openstreetmap.org/browse/way/31495194

But I just converted a library point to a building and it rendered the icon correctly but seemed to omit the name, examples:

Cary Memorial Library in Lexington, MA, USA:

http://www.openstreetmap.org/browse/way/39710653

also a church:

http://www.openstreetmap.org/browse/way/39712986

has there been an additional change since this patch?

comment:5 Changed 10 years ago by fiveisalive

Cc: fiveisalive added

comment:6 Changed 10 years ago by jburgess777@…

Resolution: fixed
Status: reopenedclosed

There was a bug in this patch which meant that the text-poly layer was not rendering. The issue is that the text style has a filter which references the aeroway column but this is not returned by the text-poly layer. This was fixed in osm.xml r17346.

I have just updated the live rendering with this fix so the tiles should be fixed when they are rendered again.

comment:7 Changed 10 years ago by fiveisalive

I can confirm that this fix appears to work.

Note: See TracTickets for help on using tickets.