Opened 9 years ago

Closed 9 years ago

#2182 closed defect (duplicate)

RTL text word-wraps in reverse order

Reported by: salty-horse Owned by: steve8@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

When a hebrew string is broken into several lines, the lines appear in reverse.

For example, the text (in English for demonstration purposes) "FED CBA" wraps as:

FED
CBA

When it should wrap as:

CBA
FED

And a real-world example:

http://www.openstreetmap.org/?lat=32.1724&lon=34.8106&zoom=14&layers=B000FTF

This is "הרצליה פיתוח"

It is shown as

פיתוח
הרצליה

instead of

הרצליה
פיתוח

Change History (1)

comment:1 Changed 9 years ago by Ldp

  • Resolution set to duplicate
  • Status changed from new to closed

Marked as duplicate of #1515. Comments can be made there.

Note: See TracTickets for help on using tickets.