Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2206 closed defect (fixed)

church gray or brown?

Reported by: wiso Owned by: Ldp
Priority: minor Milestone:
Component: mapnik Version:
Keywords: church, building Cc: giurrero@…

Description

area tagged with

amenity = place_of_worship religion = christian

rendered as a gray area with a cross. But:

building = yes amenity = place_of_worship religion = christian

rendered as a brown (red) area with a cross

Change History (7)

comment:1 Changed 10 years ago by Ldp

Owner: changed from mapnik-team@… to Ldp
Status: newassigned

I can see what's going on here.

comment:2 Changed 10 years ago by ldp

Resolution: fixed
Status: assignedclosed

(In [17172]) Don't overpaint place_of_worship area with generic building. Fixes #2206

comment:3 Changed 10 years ago by wiso

Resolution: fixed
Status: closedreopened

Your fix doesn't work. Look here:

http://www.openstreetmap.org/?lat=45.35378&lon=9.6561&zoom=16&layers=B000FTF

there are two churches, one on the left and one on the right. The first is gray, the second is brown. The tiles are updated:

http://c.tile.openstreetmap.org/16/34527/23483.png/status Tile is clean. Last rendered at Wed Aug 19 19:21:38 2009

I've also tried to regenerate tiles locally with mapnik, but the result is the same

comment:4 Changed 10 years ago by Ldp

This ticket was auto-closed the moment I committed the fix to the stylesheet, but we still have to wait for it to be deployed on the tile server, and for tiles be rerendered with it. That can take anywhere from a few hours to a week.

So, I would give it a few more days until it starts showing up.

comment:5 in reply to:  4 ; Changed 10 years ago by wiso

Replying to Ldp:

This ticket was auto-closed the moment I committed the fix to the stylesheet, but we still have to wait for it to be deployed on the tile server, and for tiles be rerendered with it. That can take anywhere from a few hours to a week.

So, I would give it a few more days until it starts showing up.

you did the change on 19 aug 09 16:23, the tile were rendered on 19 aug 09 19:21.

comment:6 in reply to:  5 Changed 10 years ago by wiso

Resolution: fixed
Status: reopenedclosed

Replying to wiso:

Replying to Ldp:

This ticket was auto-closed the moment I committed the fix to the stylesheet, but we still have to wait for it to be deployed on the tile server, and for tiles be rerendered with it. That can take anywhere from a few hours to a week.

So, I would give it a few more days until it starts showing up.

you did the change on 19 aug 09 16:23, the tile were rendered on 19 aug 09 19:21.

Ok, now it seems ok

comment:7 Changed 10 years ago by Ldp

wiso, keep an eye on

http://trac.openstreetmap.org/browser/applications/rendering/mapnik

and if you see the osm-template.xml and osm-template-fontset.xml updated with the messsage 'sync mapnik style with osm.xml @ rNNNNN' where NNNNN is equal to the current osm.xml revision, *that's* when the stylesheet was deployed to the main tile server.

I know, it's a bit confusing.

Note: See TracTickets for help on using tickets.