Opened 10 years ago

Closed 9 years ago

#2209 closed defect (invalid)

fails to select "large" relations -> impossible to add new relation member

Reported by: tesche Owned by: cbro@…
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

I understand the way to add members to an existing relation (e.g. a new role=inner area to a type=multipolygon relation) is to select (i.e. click on) both the bounding box of the relation and the new area and then click on Relation -> AddMember? from the menu.

I have used this successfully in version 0.13, but in version 0.14 I have severe difficilties with selecting the relation. it has worked at least once, though only after some time of doing some things I don't remember, but mostly it does not work. when I click on a known relation member the relations bounding box appears, but when I then click on that bounding box it will not be selected. instead, nothing at all happens. it appears to me - though I haven't tested it that thoroughly - that this applies primarily for "large" relations, i.e. relations that span over a large geographical area, which I may not have completely downloaded or which I may not have completely visible on the screen.

appart from wanting to have this fixed I think that ticket #1469 "Allow selection of map objects by ID, rather than mouseclick" is a good idea.

Change History (3)

comment:1 Changed 10 years ago by BearT

I'm not sure if we're talking about the same bug, but do have problems selecting ways too? Or do you only have problems selecting relations? Because in the last builds (svn) I had the impression, that selecting ways does not always work as expected. I select a way, move it a bit and afterwards the way seems unselectable. After a bit of zooming in/out and moving the map, the same way is selectable again.

I did not report this so far, because I wasn't able to reproduce it, but since you reported some selection problems I'm curious if our experiences are caused by the same bug.

comment:2 Changed 10 years ago by Chris Browet

Have you tried with "View-Show relations" enabled?

If a relation is not completely downloaded (i.e. shows in red), it is read-only and not selectable. Relations in green should be selectable.

To be sure to download all members of a relation, tick "Resolve all relations" in the download box (it is persistent, so all further "Download more" will resolve relations, too).

comment:3 Changed 9 years ago by Chris Browet

Resolution: invalid
Status: newclosed

Assumed invalid

Note: See TracTickets for help on using tickets.