Opened 9 years ago

Closed 8 years ago

#2218 closed enhancement (fixed)

aeroway=runway,taxiway ref=* not rendering

Reported by: imrehg@… Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: taxiway runway rendering convention Cc:

Description

The wiki for the aeroway=taxiway does not have any direct recommendation for naming taxiways, but has a "Useful combinations" entry for key:ref. The problem is, that at the moment the name=* tags are shown as names for taxiways, but the ref=* tags are not.

In use by the people working on the airports, they probably don't distinguish between "name" and "reference" since those have very close "dictionary meanings". For the OSM tagging convention it is different, and I feel "ref" is more appropriate, just as it is used, for example for freeways...

So, I propose, that in case of runways and taxiways if there's a "ref" tag, that is rendered on the map. Not sure about existing name=* tags, they can be converted (preferred) or be a "fallback" rendering information (not as good since does not encourage a single convention).

Change History (5)

comment:1 Changed 9 years ago by steve8@…

Can you give a URL of an airport where refs are in place and I will have a look?

comment:2 Changed 9 years ago by imrehg@…

comment:3 Changed 9 years ago by steve8@…

  • Resolution set to fixed
  • Status changed from new to closed

Done

comment:4 Changed 9 years ago by imrehg@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

It renders now, but the arrangement is not that good-looking.
With ref=* all the text are shown horizontal, while the name=* tags were rendered parallel to the ways.
Compare to the above link another airport, that uses the name=* tags for taxiways/runways:
http://www.openstreetmap.org/?lat=41.97473&lon=-87.91334&zoom=16&layers=B000FFF

I'd say the parallel rendering looks quite a bit nicer. If others disagree, then just close this ticket once again.
Thanks a lot!

comment:5 Changed 8 years ago by Ldp

  • Resolution set to fixed
  • Status changed from reopened to closed

Aligned runway refs implemented a long time ago (r17605)

Note: See TracTickets for help on using tickets.