Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2219 closed defect (fixed)

Name is no longer rendered if addr:housenumber is present

Reported by: sim Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc: fiveisalive

Description

I've been mapping an area for awhile and all was fine, but about two weeks ago I noticed, that "name" is no longer rendered for buildings if "addr:housenumber" is present. This is pretty big deal for me as no one is using housenumbers here, only building names. I can of course remove housenumbers but this sounds like a weird solution.

Example:
http://www.openstreetmap.org/?lat=43.07529&lon=-89.41092&zoom=17&layers=B000FTF

Change History (10)

comment:1 Changed 8 years ago by fiveisalive

  • Cc fiveisalive added

I can confirm this, but it appears to only occur if the building is not also tagged with an amenity=library etc. that uses a special font or color. i.e. it only happens for buildings or areas which don't otherwise have special rendering:

compare which doesn't render the name:

http://www.openstreetmap.org/browse/way/29681765

with this CVS pharmacy, which does:

http://www.openstreetmap.org/browse/way/29589595

comment:2 Changed 8 years ago by sim

I've tried to add amenity=university to buildings with mixed results, name is shown, but only on low scales. That does not solve the problem.

http://osm.org/go/ZVE4jz9s

comment:3 Changed 8 years ago by ldp

  • Resolution set to fixed
  • Status changed from new to closed

(In [17690]) Favour names before house numbers again. Fixes #2219.

comment:4 Changed 8 years ago by Ldp

Should show up once deployed.

comment:5 Changed 8 years ago by fiveisalive

I guess this is not yet deployed because I tried to force it by deleting the name and addr:housenumber and re-adding but the old problem is still there:

http://www.openstreetmap.org/browse/way/36894756

Can you confirm if this has been deployed or not? Is there any way for users to check?

comment:6 follow-up: Changed 8 years ago by Ldp

To see if it's been deployed, check to see if the osm-template.xml and osm-template-fontset.xml have been synched to the osm.xml.

http://trac.openstreetmap.org/browser/applications/rendering/mapnik

Currently it hasn't been deployed yet. Sometimes it takes an hour, sometimes a few days.

comment:7 in reply to: ↑ 6 Changed 8 years ago by fiveisalive

Replying to Ldp:

To see if it's been deployed, check to see if the osm-template.xml and osm-template-fontset.xml have been synched to the osm.xml.

http://trac.openstreetmap.org/browser/applications/rendering/mapnik

Currently it hasn't been deployed yet. Sometimes it takes an hour, sometimes a few days.

Still hasn't been deployed for over a week now. Who should we nudge to do the synching?

comment:8 Changed 8 years ago by Ldp

It has been deployed and is currently rendering.

comment:9 Changed 8 years ago by sim

Thank you for working on this. It seems that there still some issues with rendering, on fine scale, some object names aren't rendered. I was waiting for 2-3 days now.
http://osm.org/go/ZVE4mBi4K--

comment:10 Changed 8 years ago by Ldp

That was just a case of old tiles. I forced a rerender, and the names showed up.

Note: See TracTickets for help on using tickets.