Opened 10 years ago

Closed 10 years ago

#2246 closed defect (duplicate)

Geotagged images with minus longitiudes incorrectly shown

Reported by: kevjs1982 Owned by: cbro@…
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc: merkaartor@…

Description

When importing images Geotagged using GeoSetter? (they display okay in Google Earth) which have negative longitude value they are displayed at longitude value without the minus sign.

The attached image should be displayed at lat=52.94490900; lon=-1.08963100; but is actually displayed at lat=52.94490900; lon=1.08963100;

Attachments (1)

DSCN1657.JPG (54.6 KB) - added by kevjs1982 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by kevjs1982

Attachment: DSCN1657.JPG added

comment:1 Changed 10 years ago by Chris Browet

I don't have the problem on Windows.

If not windows, please state OS/Qt version/exiv2 version...

comment:2 Changed 10 years ago by Chris Browet

Cc: merkaartor@… added

Someone else noticed this?

comment:3 Changed 10 years ago by Toby Speight

I fixed an issue with the sign of longitude and latitude a few months ago. My images from gpscorrelate were appearing the wrong side of the Greenwich Meridian.

To diagnose, it would be useful to have a dump of the data from the GPS* tags in the exif. E.g. from one of my images:

$ exiv2 -pv 20090909-121938.jpg | grep '^0x.... GPSInfo'
0x0000 GPSInfo      GPSVersionID                Byte        4  2 0 0 0 
0x0001 GPSInfo      GPSLatitudeRef              Ascii       2  N
0x0002 GPSInfo      GPSLatitude                 Rational    3  57/1 28/1 4203/100
0x0003 GPSInfo      GPSLongitudeRef             Ascii       2  W
0x0004 GPSInfo      GPSLongitude                Rational    3  4/1 5/1 3561/100
0x0005 GPSInfo      GPSAltitudeRef              Byte        1  0 
0x0006 GPSInfo      GPSAltitude                 Rational    1  764675/5000
0x0007 GPSInfo      GPSTimeStamp                SRational   3  12/1 19/1 38/1
0x0012 GPSInfo      GPSMapDatum                 Ascii       7  WGS-84
0x001d GPSInfo      GPSDateStamp                Ascii      11  2009:09:09

Obviously, it's the GPSLongitude and GPSLongitudeRef that are particularly interesting to this issue.

comment:4 in reply to:  3 Changed 10 years ago by Toby Speight

Replying to tms13:

I found the mail containing my patch.

According to Chris Browet's followup, he applied it on 28 April 2009.

comment:5 Changed 10 years ago by Chris Browet

Resolution: duplicate
Status: newclosed

Probably why I cannot reproduce in 0.14 ;-)

To the reporter: Please upgrade to 0.14

Note: See TracTickets for help on using tickets.