Opened 10 years ago

Closed 10 years ago

#2289 closed enhancement (duplicate)

[PATCH] Add links to wiki Key:* and Tag:* pages from /browse/* pages

Reported by: avar Owned by: Tom Hughes
Priority: major Milestone:
Component: website Version:
Keywords: Cc:

Description

This patch adds links back to the wiki for /browse/* pages if there are pages describing the tag in question. See here for an example in German (DE: keys are linked to if they exist).

The list of wiki pages that describe keys/tags are retrieved with a Perl script which generates a YAML file which the rails_port reads. This script can be run periodically to get a list of new pages that have been added to the wiki.

The code I've added to app/views/browse/_tag.html.erb works but could probably use cleanup/placing somewhere else because I don't know Ruby or RoR really.

Attachments (1)

add-links-to-wiki.patch (28.0 KB) - added by avar 10 years ago.
Patch to add this feature

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by avar

Attachment: add-links-to-wiki.patch added

Patch to add this feature

comment:1 Changed 10 years ago by StefanB

Seems to be exact duplicate of #2245. See #2245 for TomH's performance considerations.

comment:2 Changed 10 years ago by Tom Hughes

Resolution: duplicate
Status: newclosed

Duplicate of case #2245.

Note: See TracTickets for help on using tickets.