Opened 10 years ago

Closed 5 years ago

#2294 closed defect (duplicate)

[amenity-points] Some names wrap, some don't.

Reported by: Geochang scribe Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

I've noticed that some names wrap vertically, almost with a line break on every word, and some don't wrap, making a long horizontal label.

For example:

http://osm.org/go/54z6C6pPp-

You can see Hyeseong Girls' Middle School, Gaenjiseu and Yeongnak Church render nice and compactly, but Eokjo Fish Restaurant, Arim Mutual Savings and Sangdong Gas Station render horizontally only.

I think that names should render in the same way for all POIs, in the vertical, wrapped style. Certainly, if there are two pieces of code doing the same thing, but they happen to do it slightly differently, they should be rationalised to avoid code duplication and the likelihood of bugs.

Oh, and my library here renders the name: http://osm.org/go/54z6I5hHS--

But this one doesn't: http://osm.org/go/54z6JAiF4--

Is it because it's a horizontal label and too long?

Thank you.

Change History (5)

comment:1 Changed 10 years ago by Ldp

I agree about line breaks.

And the library is probably caused by the name clashing with the gate symbols. Should also be fixed if it's rendered multi line.

comment:2 Changed 5 years ago by math1985

Summary: Some names wrap, some don't.[placenames] Some names wrap, some don't.

comment:3 Changed 5 years ago by math1985

Summary: [placenames] Some names wrap, some don't.[general] Some names wrap, some don't.

comment:4 Changed 5 years ago by math1985

Summary: [general] Some names wrap, some don't.[amenity-points] Some names wrap, some don't.

Solution: let all POI names wrap.

comment:5 Changed 5 years ago by math1985

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.