Opened 11 years ago

Closed 8 years ago

#2295 closed defect (fixed)

house number with concave buildings

Reported by: wiso Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: house, number, concave Cc:

Description

Look here:

http://www.openstreetmap.org/?lat=45.30295&lon=9.50543&zoom=17&layers=B000FTF

I think the best solution is that the house number is rendered onto the building. The problem is with concave buildings.

Change History (4)

comment:1 Changed 11 years ago by Tom Hughes

Component: adminmapnik
Owner: changed from Tom Hughes to mapnik-team@…

Moving to the mapnik component, but this is really a limitation of mapnik's current placement logic when rendering a point for a polygon geometry and not something we can do much about in our stylesheet.

comment:2 Changed 11 years ago by Ldp

Indeed, mapnik needs fixing, not the stylesheet.

comment:3 Changed 11 years ago by Ldp

Same basic reason as #2306

comment:4 Changed 8 years ago by Ldp

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.