Opened 10 years ago

Closed 10 years ago

#2307 closed defect (invalid)

loss of function in Potlatch

Reported by: EdHillsman Owned by: Tom Hughes
Priority: critical Milestone:
Component: api Version:
Keywords: trace editor Cc:

Description

The option to edit uploaded GPS traces has quit working. On Friday 9/18 I accessed an uploaded trace as part of a demonstration of OSM to a class, and there were no problems. Last evening (9/24), and again this morning, I tried to edit using the trace, and encountered several problems, which I have repeated several times, on two different computers (a Macintosh running OSX 5.x at home, with a Safari browser, and a Dell at work running Windows XP Professional with Firefox browser 3.0.14; no prior problems with Potlatch on either machine).

(1) in the list of all traces (after selecting the work-with-traces tab), the icons showing the trade at the far left still appear in the public list, but when I request just my traces, the icons for my individual traces no longer appear. In Safari, I see the "broken image link" symbol. In Firefox at work I just see the text left-justified and starting where the image would have been.

(2) after clicking "edit" for the trace from my individual list, and choosing "edit with save" when the editing window starts to open, the editor opens to a screen of gray tiles. Switching to the view tab shows the map centered at the North Pole. This does not happen every time I do this, just most of the time. I have tried it with another trace I uploaded some time ago and it has happened with that one, too.

(3) on those occasions where the editor does not re-set to the North Pole, it takes an extraordinarily long time to download the data for the area shown in the editing window, even when I zoom in tightly to reduce the area covered. About half the time the data never completely loads.

(4) since first encountering this problem, the trace to be edited has never appeared in the editing window, even when it looks like the data for the window has loaded completely.

I am scheduled to do another demonstration in about two weeks, to a large group of incoming students. When Potlatch is functioning normally, there is no problem, but the way it is performing now, I can't do the demo or advise them what to do if they are interested in OSM.

Ed Hillsman ehillsman@… hillsman@…

Change History (2)

comment:1 Changed 10 years ago by Richard

Component: potlatch (flash editor)api
Owner: changed from richard@… to Tom Hughes

This appears to be a core API error rather than Potlatch-specific. http://www.openstreetmap.org/trace/450975/data.xml , for example, is currently giving a 500.

comment:2 Changed 10 years ago by Tom Hughes

Resolution: invalid
Status: newclosed

As reported on the platform status (on the front page of the wiki and at http://wiki.openstreetmap.org/wiki/Platform_Status) old traces (those uploaded before Tuesday evening) are not currently available due to a hardware failure.

The current ETA for this to be fixed is Friday evening (25th September).

Note: See TracTickets for help on using tickets.