Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2337 closed enhancement (wontfix)

Add 'Submit A Ticket' to the main OSM page

Reported by: acrosscanadatrails@… Owned by: Tom Hughes
Priority: trivial Milestone: Wishlist
Component: website Version:
Keywords: submit ticket main website Cc:

Description

Hi, On the main website, where is lists in a grey box, the following

Help & Wiki News blog Shop Map key

I think it would be helpful to have a 'Submit a ticket', or the put in the statement 'Have a suggestion for improvement?, Submit a ticket'

This way, it might encourage more use of this site. And perhaps show the difference between defining what tags to use (wiki.openstreetmap.org) and showing projects, than for actively making improvements to the main website.

Hope thats clear, Thanks. Sam

Change History (6)

comment:1 Changed 10 years ago by Tom Hughes

Resolution: wontfix
Status: newclosed

No - screen real estate is precious and we have no need to encourage random requests for enhancement as we have far more tickets already than we have resource to do anything about them.

comment:2 Changed 10 years ago by acrosscanadatrails@…

Milestone: OSM 0.5Wishlist
Priority: minortrivial
Resolution: wontfix
Status: closedreopened
Version: 1.0

However, i don't think that ticked should have been assigned to you (directly) It just automatically assigned you to it. (So you probably got emailed directly)

Perhaps i would have indicated 'trivial', as this could have been left open so then others could have commented on it?

The idea is to try and limit the number of feature requests on the main talk@… discussion list, and be able to filter the discussions of the wiki site, to become focused on actual solutions to problems, and actually make some concrete recommendations. When many discussions just end up talking in circles. At least here in this trac site, discussions can be focused. As perhaps my suggestion wasn't good, however, with some more discussion it could lead to some better recommendation that would solve a problem.

As clearly, you indicated the fact of limited resources. Using other peoples power a small sub-commitee, would be able to help me out with this idea. Then once it becomes more 'concrete' THEN it should get emailed to you directly.

And in this case, the problem is 'submitting new ideas to the main talk list and not knowing of this sites existence.'

The more people using this site, the more effective of a tool it can be. :)

comment:3 Changed 10 years ago by Tom Hughes

Resolution: wontfix
Status: reopenedclosed

I don't care how many comments you get - it's a bad idea.

In fact this ticket is a canonical example of the kind of tickets I don't like if only because it wants to add something to the home page - do you know how many people have a bright idea for something they would like adding the to home page? Quite a lot I can tell you.

Space on the home page is clearly very valuable and I am pretty much vetoing all attempts to add anything to it until such time as it is properly redesigned as every time we add something it pushes something else further down the page which leads to complaints from the supporters of whatever item loses out.

People blathering endlessly on talk@ is bad. Doing it on tickets in trac is far, far, far worse as I'm pretty much the only person even attempting to keep trac tickets under control.

Trac does not (as far as I know) support any of the concepts your proposal seems to require of subcommittees punting tickets round in endless circles.

comment:4 Changed 10 years ago by acrosscanadatrails@…

In fact this ticket is a canonical example of the kind of tickets I don't like if >only because it wants to add something to the home page - do you know how many >people have a bright idea for something they would like adding the to home page? >Quite a lot I can tell you.

Actually, i'd like to know. Or maybe there is a section on this site just for these 'wish list' bright ideas. (maybe goofie ideas, but that's how good ideas are formed)

Space on the home page is clearly very valuable and I am pretty much vetoing all >attempts to add anything to it until such time as it is properly redesigned as >every time we add something it pushes something else further down the page which >leads to complaints from the supporters of whatever item loses out.

That's the same philosophy as Google, which is good. I like how there is the option of setting it to a 'milestone' that way, this idea get put into its place for a future website redesign.

People blathering endlessly on talk@ is bad. Doing it on tickets in trac is far, >far, far worse as I'm pretty much the only person even attempting to keep trac >tickets under control.

But you don't have to be, doesn't the osm forum host (endless battering?) at least its organized. It's only those items that are listed as 'major', and 'critical' for these ones listed as 'trivial' why not let the community banter it out, until someone makes a comment of a solution. After all positives and negatives are discussed, then it becomes clearer.

Trac does not (as far as I know) support any of the concepts your proposal seems to >require of subcommittees punting tickets round in endless circles.

The only thing that i see on this site that is missing is a way to see all of the tickets (open/closed, all priority levels) so then i can find this ticket quickly, a well as a way to merge all the stuff thats now listed in the 'Development Forum' http://forum.openstreetmap.org/viewforum.php?id=13

It looks like there are alot of suggestions and ideas, but might not make it over to this site. (it's not very active, because there a currently too many places to submit ideas)

comment:5 Changed 10 years ago by Tom Hughes

You can create lists of tickets filtered in any way you like using the query tool:

http://trac.openstreetmap.org/query

comment:6 Changed 10 years ago by Tom Hughes

Oh and I have no idea about anything that may or may not go on in the forums as I don't read them at all.

Note: See TracTickets for help on using tickets.