Opened 10 years ago

Closed 10 years ago

#2348 closed defect (fixed)

Ctrl-T should not be used for the "Straighten" function

Reported by: chris66 Owned by: richard@…
Priority: minor Milestone:
Component: potlatch (flash editor) Version:
Keywords: CTRL-T Firefox Key Cc:

Description

For the "Straighten" function only key "T" should be used and not CTRL-T, because this is used in Firefox to open a new tab.

When a shape is selected this could lead to use this function by accident.

See http://img193.imageshack.us/i/waldkreis.jpg/ for an example where a forest has been circulized by accident.

Change History (3)

comment:1 Changed 10 years ago by Richard

Does Firefox really pass the keypress through to Flash Player as well as acting on it itself? That's beyond retarded if so - I can't reproduce it on 3.0.6 for OS X.

comment:2 Changed 10 years ago by fx99

Talking for Firefox 3.5.3 on a Windows XP system the situation is as follows: on "normal" tabs, CTRL-T opens a new tab. When working with potlatch, this does never happen, but if a boundary or such is selected it is converted to a circle.

comment:3 Changed 10 years ago by Richard

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.