Opened 10 years ago

Closed 9 years ago

#2356 closed defect (fixed)

Rendering landuse=forest vs natural=wood

Reported by: Aleksandr Dezhin Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: wood forest Cc: a.dezhin@…

Description

Currently landuse=forest begin rendered at z=9, natural=wood only at z=10. But usage of these tags almost identical. So, I propose to raise the level of rendering natural=wood to z=9. Colors may also be made equally, I propose light green as current natural=wood.

Current rules encourage people to rather strange behavior, such as using tags landuse=forest and natural=wood together.

Change History (8)

comment:1 Changed 10 years ago by komzpa@…

I agree that forest should be at least rendered on same zoomlevels as wood. Colors may be made slightly different, but seems for most uses they probably should be the same.

comment:2 Changed 10 years ago by ldp

Resolution: fixed
Status: newclosed

(In [18020]) Wood rendering starting at z9, same as forest. Fixes #2356. Colour unchanged.

comment:3 Changed 10 years ago by Aleksandr Dezhin

Resolution: fixed
Status: closedreopened

It was more than three weeks, but nothing has changed. It seems the problem is not in the duration of the update.

Example tile: http://a.tile.openstreetmap.org/9/309/159.png http://www.openstreetmap.org/?lat=55.999&lon=37.59&zoom=9&layers=B000FTF

comment:4 Changed 10 years ago by Ldp

Resolution: fixed
Status: reopenedclosed

Actually, it is working.

There are 2 issues:

  • It took an extraordinarily long time this time to deploy the new style stylesheet, which happened only a few hours ago.
  • Low zoom tiles aren't automatically rerendered, but normally only during a full planet import. Which happens irregularly every few weeks or so.

I forced a rerender on your example tiles.

comment:5 Changed 10 years ago by Aleksandr Dezhin

Thanks for the explanation and quick response.

comment:6 Changed 9 years ago by Aleksandr Dezhin

Resolution: fixed
Status: closedreopened

In [21591] stevechilton raised level of rendering landuse=forest to z=8. Please raise the level of rendering natural=wood to z=8 too.

comment:7 Changed 9 years ago by Aleksandr Dezhin

... or revert back landuse=forest to z=9

comment:8 Changed 9 years ago by Ldp

Resolution: fixed
Status: reopenedclosed

landuse=forest to z8, r22271

Note: See TracTickets for help on using tickets.