Opened 10 years ago

Closed 10 years ago

#2395 closed defect (fixed)

Potlatch crashes/hangs when zooming out (too much data fetched?)

Reported by: Ole Laursen Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

I can't use potlatch in Denmark in zoom levels farther out than the most zoomed in and second to most zoomed in.

To reproduce, go to big city Aalborg, Denmark, zoom in as much as possible, then press "edit". Once in Potlatch, zoom out some steps. Potlatch eventually becomes more and more unresponsive, eventually hanging the browser, apparently from all the data fetched. Maybe the problem is that someone recently imported all addresses in Denmark? At higher zoom levels, there's got to be several thousands of those.

If you could limit the amount of data fetched, or add a "stop now, goddamnit" button it would be nice. I have lost a couple of edits because I didn't manage to press "save" before the browser died completely. It's especially annoying because Ctrl+Page up/down is zoom, so I accidentally zoom out when trying to switch to another browser tab. :-(

I have given up mapping some larger features near Aalborg for the time being.

PS: Thanks for the editor! It's so nice to be able to hit "Edit" in the browser and immediately fix a bug when you notice it on the map. :)

Change History (1)

comment:1 Changed 10 years ago by Richard

Resolution: fixed
Status: newclosed

Potlatch now warns if you're trying to load too many ways, and offers the opportunity to zoom in.

Note: See TracTickets for help on using tickets.