Opened 10 years ago

Closed 6 years ago

#2420 closed defect (fixed)

name=... of abandoned railways rendered

Reported by: ToB Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

Abandoned (contrary to disused and used) railways are not rendered. However, if they have a name= tag, that tag is rendered, which looks a bit odd. Example:

http://www.openstreetmap.org/?lat=50.992271&lon=6.274332&zoom=18&layers=B000FTTTT

Change History (2)

comment:1 Changed 9 years ago by EvanE

In the example http://www.openstreetmap.org/?lat=50.992271&lon=6.274332&zoom=18&layers=B000FTTTT the abandoned railway is today rendered as a dotted line.

This seems for me, as if the problem is solved.

Am I allowed to close this ticket or change type/priority? (I am not a member of the mapnik team.)

comment:2 Changed 6 years ago by julianladisch

Resolution: fixed
Status: newclosed

The example mentioned from ToB in the initial description is a "railway = disused" case. Mapnik now renders it using dotted line and name: http://www.openstreetmap.org/?mlat=50.9872&mlon=6.2744#map=16/50.9872/6.2744

Here is an example of "railway = abandoned". Mapnik now renders it with dotted line and name as well: http://www.openstreetmap.org/?mlat=51.5196&mlon=9.8006#map=16/51.5196/9.8006&layers=N

The issue is fixed.

Note: See TracTickets for help on using tickets.