Opened 10 years ago

Closed 10 years ago

#2424 closed enhancement (fixed)

Look at landuse / natural values for displaying relation summaries

Reported by: Vid the Kid Owned by: richard@…
Priority: minor Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

Here's an area I've been working on lately: http://www.openstreetmap.org/?lat=40&lon=-83&zoom=12. I've been basically filling the map with landuse=* and natural=* areas, based on Yahoo! imagery. Rather than having a bunch of closed ways that overlap and share nodes, it seems to be a time saver to use multipolygon relations -- not to mention producing data that's more elegant. And some people may call me crazy for trying to do something so complicated in Potlatch, but that's what I'm doing.

The problem is that I can wind up with several multipolygon relations loaded at a time, all of which have only the tags "type=multipolygon" and "landuse=*" or "natural=*". And unless I actually open up the relation tag editor, Potlatch refers to each of these relations as simply "multipolygon".

I haven't studied ActionScript? before, but it looks a lot like several other languages I've worked with. So I'm going to attach here a replacement I've come up with for some functions in relation.as. This should make it a little more intuitive to work with multipolygon relations that have tags "place=*", "amenity=*", "leisure=*", "landuse=*", or "natural=*". (These are the types of multipolygon features that seem to me most likely to share their outer ways with other features, and therefore have the tagging on the relation rather than the ways.) This will be especially helpful for relations that don't have "name=*" or "ref=*" tags, which is quite possible of "landuse=*" and "natural=*" multipolygons.

Attachments (1)

relation.as fragment.txt (2.8 KB) - added by Vid the Kid 10 years ago.
Replacement of some functions in relation.as

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by Vid the Kid

Attachment: relation.as fragment.txt added

Replacement of some functions in relation.as

comment:1 Changed 10 years ago by Richard

Resolution: fixed
Status: newclosed

Makes a lot of sense - and thank you for the patch! Will be in the next version.

Note: See TracTickets for help on using tickets.