Opened 10 years ago

Closed 7 years ago

#2429 closed defect (duplicate)

Increase default maximum zoom level in JMapViewer's AbstractOsmTileSource class for NearMap in JOSM

Reported by: morb_au Owned by: steve@…
Priority: minor Milestone:
Component: applet Version:
Keywords: josm nearmap jmapviewer abstractosmtilesource slippymap Cc:

Description

I was trying to add NearMap? as a custom tile source in JOSM r2255. It has detail down to zoom level 21 with plans to level 22 in future (3.5cm per pixel resolution).

I tried to add it into JOSM as a custom slippymap, josm preferences says:

slippymap.custom_tile_source_1.ext=jpg
slippymap.custom_tile_source_1.name=Nearmap via Morb_au server
slippymap.custom_tile_source_1.url=http://206.123.75.6/cgi/ms/test/nearmap.aerial.slippymap
slippymap.last_zoom_lvl=20
slippymap.max_zoom_lvl=21
slippymap.min_zoom_lvl=13

The problem is the slippymap.max_zoom_lvl is not being honoured, it seems to get bounded at 18, and the bounding appears to happen in the JMapViewer. Hence I've entered the defect here rather than at JOSM.

Not sure what else to add at this point.

Change History (2)

comment:1 Changed 10 years ago by morb_au

p.s. The offending portion could be in http://svn.openstreetmap.org/applications/viewer/jmapviewer/src/org/openstreetmap/gui/jmapviewer/OsmTileSource.java

I don't have much of a java compilation setup, so all I've done is desk-check the trail of dependencies. I could be completely wrong!

comment:2 Changed 7 years ago by don-vip

Resolution: duplicate
Status: newclosed

Duplicate of #josm3971

Note: See TracTickets for help on using tickets.