Opened 13 years ago

Closed 13 years ago

#243 closed defect (worksforme)

New traces, Landsat images, not appearing in web edit applet (Mac OS X)

Reported by: Peter Rukavina Owned by: steve@…
Priority: major Milestone:
Component: applet Version:
Keywords: os x, mac, java Cc:

Description

I'm a new OSM user.

I'm running Mac OS X 10.4.6 with "Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-112)" and I'm attempting to use the OSM web editing applet to manage GPS traces that I've uploaded (http://www.openstreetmap.org/traces/user/ruk). I've tried this in Safari, Firefox and Camino with the same results.

The applet loads, but only my first set of traces appears, and only one Landsat tile appears. Attempts to zoom in and out (with [ and ]) result in "Loading tile..." appearing forever -- no map redraw happens at the new zoom level, ever. Here's a screen shot showing this in action:

http://ruk.ca/images/osmproblem.png

Attachments (1)

osm-java-log.txt (8.1 KB) - added by Peter Rukavina 13 years ago.
Java console output -- launch the web edit applet under OS X / Safari

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by Peter Rukavina

Attachment: osm-java-log.txt added

Java console output -- launch the web edit applet under OS X / Safari

comment:1 Changed 13 years ago by Peter Rukavina

I now see all of my uploaded GPS traces, but still only one Landsat tile, and if I zoom in/out or pan, I still receive "Loading tile..." messages on the screen indefinitely.

comment:2 Changed 13 years ago by Peter Rukavina

Resolution: worksforme
Status: newclosed

A day later, and everything seems to be working as documented. From my [primitive] understanding of how things work, it looks like this was all a result of some problems fetching the Landsat imagery for the background, which caused everything else to fail.

Note: See TracTickets for help on using tickets.