Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2439 closed defect (fixed)

Mapnik not rendering an area

Reported by: Pontiac_CZ Owned by: jburgess777@…
Priority: trivial Milestone:
Component: mapnik Version:
Keywords: Cc: mapnik-team@…

Description

Here - http://www.openstreetmap.org/?lat=49.168832&lon=17.51169&zoom=18&layers=B000FTF. Missing 4 houses right in the center of this view. It's been several days (four) since they were created. For instance, one of missing houses: http://www.openstreetmap.org/browse/way/43922713 (as you can see, OSM knows about it, it's just Mapnik that ignores it :-)

Change History (3)

comment:1 Changed 10 years ago by Ldp

Cc: mapnik-team@… added
Owner: changed from mapnik-team@… to jburgess777@…
Priority: majortrivial

It's possible that for some reason they never made it into the diff files used to load updates to the mapnik db. A quick test for this would be to 'touch' the buildings (edit a tag for instance) and then upload.

comment:2 Changed 10 years ago by jburgess777@…

Resolution: fixed
Status: newclosed

I don't know what went wrong with way 43922713, the ndoes were missing from the mapnik database. I have pushed that way back into the mapnik rendering database and it is showing up now. Was that way the only one missing? It was the only one in that particular changeset.

We have seen some changesets going missing from the diff stream over the past few days so it is possible this is the cause. We're investigating this already.

Please re-open the bug if there are other ways which are not showing up. I'll fix them too if you can give me the way IDs.

comment:3 Changed 10 years ago by jburgess777@…

I just found the other 3 ways that you said were missing. It is odd they would all get lost together. (IDs: 43922714, 43922711 & 43922715). These should all appear now, you may need to refesh the tiles in your browser.

Note: See TracTickets for help on using tickets.