Opened 8 years ago

Closed 8 years ago

#2474 closed enhancement (fixed)

[PATCH] osmosis doesn't give warnings when failing to parse version="" attribute in 0.5 OSM files read with the 0.6 driver

Reported by: avarab@… Owned by: brett@…
Priority: minor Milestone:
Component: osmosis Version:
Keywords: Cc:

Description

When I use --read-xml to parse 0.5 OSM files osmosis will die with an exception in parseInt because it can't find the version="" attribute. This patch gives a meaningful error message in this case.

Attachments (1)

osmosis-warning.patch (4.3 KB) - added by avarab@… 8 years ago.
Croak with an exception when osmosis can't find version="" in 0.6 OSM files

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by avarab@…

Croak with an exception when osmosis can't find version="" in 0.6 OSM files

comment:1 Changed 8 years ago by brett@…

  • Resolution set to fixed
  • Status changed from new to closed

Patch applied with some minor formatting updates to fix checkstyle.

Note: See TracTickets for help on using tickets.