Opened 10 years ago

Closed 7 years ago

#2499 closed enhancement (fixed)

Nominatim: Administrative/State names - "translated" version not used?

Reported by: ToB Owned by: twain
Priority: major Milestone:
Component: nominatim Version:
Keywords: Cc: washeck

Description

I have some problems finding the right relation, but searching for "Lower Saxony" with language=DE finds:

"State Lower Saxony, Bundesrepublik Deutschland, Europa", "Administrative Lower Saxony, Bundesrepublik Deutschland"

The relation I found had name="Niedersachsen", name:en="Lower Saxony". Thus I had expected that it shows "Niedersachsen" with language=DE. However, I might have looked at the wrong relation (http://www.openstreetmap.org/browse/relation/62771).

Similarly for "Hamburg": "Hamburg, Freie und Hansestadt Hamburg, Free and Hanseatic City of Hamburg, Bundesrepublik Deutschland, Europa" -- Here, the word "Free and Hanseatic City of Hamburg" appears twice - once in German and once in English. Here, the relation http://www.openstreetmap.org/browse/relation/62782 contains also name= and name:de=. But I do not understand why it appears this time in both versions.

Change History (5)

comment:1 Changed 10 years ago by ToB

Component: adminnominatim
Owner: changed from Tom Hughes to openstreetmap@…

comment:2 Changed 10 years ago by twain

Owner: changed from openstreetmap@… to twain
Status: newassigned
Type: defectenhancement

The problem is caused by the relations not having a name:de version of the name only a 'name' version since the system currently has no way to determine the local language.

Almostly certainly your browser language preferences are: de, en, etc... which results in the system looking for (in order):

name:de, name:en, name

so without name:de then name wins

To fix this either the tag needs name:de or the system needs some way to determine the local language for every country.

comment:3 Changed 8 years ago by washeck

I was also hit by this. Do you have an idea how to determine the local language for the country and respect it in Nominatim? I don't think duplicating the tags with name="X" and name:de="X" is the way to go.

comment:4 Changed 8 years ago by washeck

Cc: washeck added

comment:5 Changed 7 years ago by Sarah Hoffmann

Resolution: fixed
Status: assignedclosed

Nominatim now has default languages for each country. The list of language mappings is available in the wiki.

Note: See TracTickets for help on using tickets.