Opened 9 years ago

Closed 8 years ago

#2514 closed defect (fixed)

No name rendering on waterway=river

Reported by: Mikado Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

Way tagged with {waterway=river; name=Name} won't have name rendered in Mapnik. Expected behavior is that name would be drawn along the way, like it is drawn on waterway=canal and waterway=stream.

Having names rendered along river ways would allow to suppress rendering of {waterway=riverbank} names, which are often drawn off the water because of river turns.

Change History (2)

comment:1 Changed 8 years ago by osm@…

I support this issue, especially now that the addition of an halo to streams creates ugly results where I used streams inside a riverbank or natural=water to have their names rendered.

comment:2 Changed 8 years ago by Ldp

Resolution: fixed
Status: newclosed

Applied and deployed in r25587.

Note: See TracTickets for help on using tickets.