Opened 10 years ago

Closed 10 years ago

#2524 closed enhancement (wontfix)

addr:city on streets is ignored

Reported by: elektranox@… Owned by: openstreetmap@…
Priority: major Milestone:
Component: nominatim Version:
Keywords: Cc:

Description

it seems nominatim currently ignores addr:city tags on streets, which may be used instead of is_in. Take a look at this example - I want to find "Otto-Wels-Straße" in Oldenburg, Germany:

Search by city name: http://nominatim.openstreetmap.org/?q=Otto-Wels-Straße,+Oldenburg&viewbox=8.21,53.1,8.22,53.09 Result: Otto-Wels-Straße in Wildeshausen, Oldenburg, Niedersachsen, Germany, World

Search by postcode: http://nominatim.openstreetmap.org/?q=Otto-Wels-Straße,+26133&viewbox=8.2,53.1,8.21,53.1 Result: Otto-Wels-Straße in Oldenburg, Niedersachsen, Germany, World

The streets in Oldenburg are connected to the city by addr:city. Can you please interpret this when importing data to the search database?

Change History (1)

comment:1 in reply to:  description Changed 10 years ago by twain

Resolution: wontfix
Status: newclosed

This has no relevance to the addr:city tag

This is caused by the (in my opinion) very broken tagging on the city relation:

http://www.openstreetmap.org/browse/relation/62409

which is named 'Oldenburg (Oldenburg), Stadt'

the name of the place is Oldenburg - this is tagging for rendering and as a result prevents nominatim from indexing it.

A similar problem can be seen on the node:

http://www.openstreetmap.org/browse/node/277023297

Note: See TracTickets for help on using tickets.