Opened 10 years ago

Closed 10 years ago

#2533 closed defect (fixed)

An unusual error happened (in 'startchangeset'). The server said: undefined method `empty?' for nil:NilClass

Reported by: chriscf Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

An unusual error happened (in 'startchangeset'). The server said: undefined method `empty?' for nil:NilClass Please try again: Potlatch will start a new changeset.

Please e-mail richard\@systemeD.net with a bug report, saying what you were doing at the time.

Editing here: http://www.openstreetmap.org/edit?lat=51.1419424&lon=-2.7001524&way=41747954&zoom=16 Attempting to fix way 41747954 by splitting it at the westmost node and removing the duplicate way that results. Place to enter summary and twitter checkbox did not appear on the summary dialog. I've tried this three times, and it's reproducible each time.

Change History (2)

comment:1 Changed 10 years ago by chriscf

I should add this was in "save" mode.

comment:2 Changed 10 years ago by Richard

Resolution: fixed
Status: newclosed

Appears to have been caused by r18895 awakening an obscure bug in some versions of Ming (the Flash compiler). Fixed.

Note: See TracTickets for help on using tickets.