Opened 10 years ago

Closed 10 years ago

#2534 closed defect (fixed)

No changeset description box => no way to save in "edit with save" mode

Reported by: Vid the Kid Owned by: richard@…
Priority: blocker Milestone:
Component: potlatch (flash editor) Version:
Keywords: changeset description UI error Cc:

Description

In either "edit live" or "edit with save" mode, as of version 1.3b, the box to enter a changeset description is missing. In "edit with save" mode, when clicking the "save" button anyway, the following error is displayed:

"An unusual error happened (in 'startchangeset'). The server said: undefined method `empty?' for nil:NilClass Please try again: Potlatch will start a new changeset."

And the data is not uploaded.

However, in "edit live" mode, edits are uploaded as they are made. Attempting to close the changset produces the same error, but at least changes have been saved...

Change History (1)

comment:1 Changed 10 years ago by Richard

Resolution: fixed
Status: newclosed

Appears to have been caused by r18895 awakening an obscure bug in some versions of Ming (the Flash compiler). Fixed.

Note: See TracTickets for help on using tickets.