Opened 10 years ago

Closed 8 years ago

#2540 closed defect (fixed)

Naval base obscures sea

Reported by: fluteflute Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: Cc: gregoryauger@…

Description

Areas of sea as marked by natural=coastline, are not rendered blue when part of a military=naval_base.

For example in Portsmouth: http://www.openstreetmap.org/?lat=50.80676&lon=-1.10397&zoom=16&layers=B000FTF

As apposed to the Osmarander (correct in my opinion rendering): http://www.openstreetmap.org/?lat=50.80676&lon=-1.10397&zoom=16

Change History (2)

comment:1 Changed 10 years ago by Ldp

It's actually caused by landuse=military, and since these can extend into water, that's what drives the current rendering.

comment:2 Changed 8 years ago by Ldp

Resolution: fixed
Status: newclosed

landuse=military is now a hatching with a faint background. That should allow the 'blue-ness' of the water to still come through.

Note: See TracTickets for help on using tickets.