Opened 10 years ago

Closed 5 years ago

#2613 closed enhancement (duplicate)

[amenity-points] building=* single nodes should be rendered in mapnik

Reported by: Polarbear Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

Currently mapnik only renders building polygons.

Many buildings with known position and unknown shape have been submitted as a single node, and should be rendered with a small square (size depending on zoom).

Osmarender does that meanwhile.

Change History (5)

comment:1 Changed 5 years ago by math1985

Summary: building=* single nodes should be rendered in mapnik[amenity-points] building=* single nodes should be rendered in mapnik

comment:2 Changed 5 years ago by math1985

Can anyone give an example of areas with many single-point houses? What should the rendering style be?

comment:3 Changed 5 years ago by Polarbear

Just found that old ticket of mine, certainly the issue is less urgent than 5 years ago when it was opened. That time before aerial images the existence of a building could just be judged from the road. Now this is only the case for very new buildings that do not show up in Bing yet.

Anyway, a recommended rendering would be the little house icon we have in JOSM, in the same colour as other buildings in mapnik, and with the house number on it, if existing.

comment:4 Changed 5 years ago by Mateusz Konieczny

I think that it is better to not encourage this kind of tagging.

comment:5 Changed 5 years ago by math1985

Resolution: duplicate
Status: newclosed

This issue is now being discussed on Github: https://github.com/gravitystorm/openstreetmap-carto/issues/806 Therefore, I will close the issue here.

Note: See TracTickets for help on using tickets.