Opened 11 years ago

Closed 10 years ago

#2644 closed defect (fixed)

Merkaartor crashes on File opening

Reported by: delta82 Owned by: Chris Browet
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

If i try opening a saved file mercaartor crashes:

<?xml version="1.0" encoding="UTF-16"?> <DATABASE> <EXE NAME="Merkaartor.exe" FILTER="GRABMI_FILTER_PRIVACY">

<MATCHING_FILE NAME="libgdal-1.dll" SIZE="21030247" CHECKSUM="0xF659FA1A" MODULE_TYPE="WIN32" PE_CHECKSUM="0x141923D" LINKER_VERSION="0x10000" LINK_DATE="02/03/2009 00:26:00" UPTO_LINK_DATE="02/03/2009 00:26:00" /> <MATCHING_FILE NAME="Merkaartor.exe" SIZE="6622208" CHECKSUM="0x22E79402" MODULE_TYPE="WIN32" PE_CHECKSUM="0x656CC2" LINKER_VERSION="0x10000" LINK_DATE="08/12/2009 08:57:36" UPTO_LINK_DATE="08/12/2009 08:57:36" /> <MATCHING_FILE NAME="mingwm10.dll" SIZE="15964" CHECKSUM="0x56F6EC70" MODULE_TYPE="WIN32" PE_CHECKSUM="0x4984" LINKER_VERSION="0x10000" LINK_DATE="12/27/2007 14:23:32" UPTO_LINK_DATE="12/27/2007 14:23:32" /> <MATCHING_FILE NAME="QtCore4.dll" SIZE="2744320" CHECKSUM="0x2D02D357" BIN_FILE_VERSION="4.5.2.0" BIN_PRODUCT_VERSION="4.5.2.0" FILE_DESCRIPTION="C++ application development framework." COMPANY_NAME="Nokia Corporation and/or its subsidiary(-ies)" PRODUCT_NAME="Qt4" FILE_VERSION="4.5.2.0" ORIGINAL_FILENAME="QtCore4.dll" LEGAL_COPYRIGHT="Copyright (C) 2009 Nokia Corporation and/or its subsidiary(-ies)" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x2A196C" LINKER_VERSION="0x10000" UPTO_BIN_FILE_VERSION="4.5.2.0" UPTO_BIN_PRODUCT_VERSION="4.5.2.0" LINK_DATE="06/20/2009 05:43:42" UPTO_LINK_DATE="06/20/2009 05:43:42" /> <MATCHING_FILE NAME="QtGui4.dll" SIZE="11268096" CHECKSUM="0x82B9E1BF" BIN_FILE_VERSION="4.5.2.0" BIN_PRODUCT_VERSION="4.5.2.0" FILE_DESCRIPTION="C++ application development framework." COMPANY_NAME="Nokia Corporation and/or its subsidiary(-ies)" PRODUCT_NAME="Qt4" FILE_VERSION="4.5.2.0" ORIGINAL_FILENAME="QtGui4.dll" LEGAL_COPYRIGHT="Copyright (C) 2009 Nokia Corporation and/or its subsidiary(-ies)" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xAC1C2F" LINKER_VERSION="0x10000" UPTO_BIN_FILE_VERSION="4.5.2.0" UPTO_BIN_PRODUCT_VERSION="4.5.2.0" LINK_DATE="06/20/2009 06:04:04" UPTO_LINK_DATE="06/20/2009 06:04:04" /> <MATCHING_FILE NAME="QtNetwork4.dll" SIZE="1392128" CHECKSUM="0xC8EFCC1B" BIN_FILE_VERSION="4.5.2.0" BIN_PRODUCT_VERSION="4.5.2.0" FILE_DESCRIPTION="C++ application development framework." COMPANY_NAME="Nokia Corporation and/or its subsidiary(-ies)" PRODUCT_NAME="Qt4" FILE_VERSION="4.5.2.0" ORIGINAL_FILENAME="QtNetwork4.dll" LEGAL_COPYRIGHT="Copyright (C) 2009 Nokia Corporation and/or its subsidiary(-ies)" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x1583EB" LINKER_VERSION="0x10000" UPTO_BIN_FILE_VERSION="4.5.2.0" UPTO_BIN_PRODUCT_VERSION="4.5.2.0" LINK_DATE="06/20/2009 05:46:21" UPTO_LINK_DATE="06/20/2009 05:46:21" /> <MATCHING_FILE NAME="QtSvg4.dll" SIZE="447488" CHECKSUM="0x7CDCF7A6" BIN_FILE_VERSION="4.5.2.0" BIN_PRODUCT_VERSION="4.5.2.0" FILE_DESCRIPTION="C++ application development framework." COMPANY_NAME="Nokia Corporation and/or its subsidiary(-ies)" PRODUCT_NAME="Qt4" FILE_VERSION="4.5.2.0" ORIGINAL_FILENAME="QtSvg4.dll" LEGAL_COPYRIGHT="Copyright (C) 2009 Nokia Corporation and/or its subsidiary(-ies)" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x7484C" LINKER_VERSION="0x10000" UPTO_BIN_FILE_VERSION="4.5.2.0" UPTO_BIN_PRODUCT_VERSION="4.5.2.0" LINK_DATE="06/20/2009 06:26:26" UPTO_LINK_DATE="06/20/2009 06:26:26" /> <MATCHING_FILE NAME="QtWebKit4.dll" SIZE="19568640" CHECKSUM="0x373B726E" BIN_FILE_VERSION="4.5.2.0" BIN_PRODUCT_VERSION="4.5.2.0" FILE_DESCRIPTION="C++ application development framework." COMPANY_NAME="Nokia Corporation and/or its subsidiary(-ies)" PRODUCT_NAME="Qt4" FILE_VERSION="4.5.2.0" ORIGINAL_FILENAME="QtWebKit4.dll" LEGAL_COPYRIGHT="Copyright (C) 2009 Nokia Corporation and/or its subsidiary(-ies)" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x12AE128" LINKER_VERSION="0x10000" UPTO_BIN_FILE_VERSION="4.5.2.0" UPTO_BIN_PRODUCT_VERSION="4.5.2.0" LINK_DATE="06/20/2009 07:53:22" UPTO_LINK_DATE="06/20/2009 07:53:22" /> <MATCHING_FILE NAME="QtXml4.dll" SIZE="510464" CHECKSUM="0x93E3B974" BIN_FILE_VERSION="4.5.2.0" BIN_PRODUCT_VERSION="4.5.2.0" FILE_DESCRIPTION="C++ application development framework." COMPANY_NAME="Nokia Corporation and/or its subsidiary(-ies)" PRODUCT_NAME="Qt4" FILE_VERSION="4.5.2.0" ORIGINAL_FILENAME="QtXml4.dll" LEGAL_COPYRIGHT="Copyright (C) 2009 Nokia Corporation and/or its subsidiary(-ies)" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x7D167" LINKER_VERSION="0x10000" UPTO_BIN_FILE_VERSION="4.5.2.0" UPTO_BIN_PRODUCT_VERSION="4.5.2.0" LINK_DATE="06/20/2009 05:44:07" UPTO_LINK_DATE="06/20/2009 05:44:07" /> <MATCHING_FILE NAME="imageformats\qgif4.dll" SIZE="41472" CHECKSUM="0x65FC3F37" BIN_FILE_VERSION="4.5.2.0" BIN_PRODUCT_VERSION="4.5.2.0" FILE_DESCRIPTION="C++ application development framework." COMPANY_NAME="Nokia Corporation and/or its subsidiary(-ies)" PRODUCT_NAME="Qt4" FILE_VERSION="4.5.2.0" ORIGINAL_FILENAME="qgif4.dll" LEGAL_COPYRIGHT="Copyright (C) 2009 Nokia Corporation and/or its subsidiary(-ies)" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x151B1" LINKER_VERSION="0x10000" UPTO_BIN_FILE_VERSION="4.5.2.0" UPTO_BIN_PRODUCT_VERSION="4.5.2.0" LINK_DATE="06/20/2009 07:58:35" UPTO_LINK_DATE="06/20/2009 07:58:35" /> <MATCHING_FILE NAME="imageformats\qico4.dll" SIZE="44032" CHECKSUM="0xE76B571A" BIN_FILE_VERSION="4.5.2.0" BIN_PRODUCT_VERSION="4.5.2.0" FILE_DESCRIPTION="C++ application development framework." COMPANY_NAME="Nokia Corporation and/or its subsidiary(-ies)" PRODUCT_NAME="Qt4" FILE_VERSION="4.5.2.0" ORIGINAL_FILENAME="qico4.dll" LEGAL_COPYRIGHT="Copyright (C) 2009 Nokia Corporation and/or its subsidiary(-ies)" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xBC14" LINKER_VERSION="0x10000" UPTO_BIN_FILE_VERSION="4.5.2.0" UPTO_BIN_PRODUCT_VERSION="4.5.2.0" LINK_DATE="06/20/2009 07:59:28" UPTO_LINK_DATE="06/20/2009 07:59:28" /> <MATCHING_FILE NAME="imageformats\qjpeg4.dll" SIZE="160256" CHECKSUM="0xC5989357" BIN_FILE_VERSION="4.5.2.0" BIN_PRODUCT_VERSION="4.5.2.0" FILE_DESCRIPTION="C++ application development framework." COMPANY_NAME="Nokia Corporation and/or its subsidiary(-ies)" PRODUCT_NAME="Qt4" FILE_VERSION="4.5.2.0" ORIGINAL_FILENAME="qjpeg4.dll" LEGAL_COPYRIGHT="Copyright (C) 2009 Nokia Corporation and/or its subsidiary(-ies)" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x333A7" LINKER_VERSION="0x10000" UPTO_BIN_FILE_VERSION="4.5.2.0" UPTO_BIN_PRODUCT_VERSION="4.5.2.0" LINK_DATE="06/20/2009 07:58:30" UPTO_LINK_DATE="06/20/2009 07:58:30" /> <MATCHING_FILE NAME="imageformats\qsvg4.dll" SIZE="32256" CHECKSUM="0xDA3898E0" BIN_FILE_VERSION="4.5.2.0" BIN_PRODUCT_VERSION="4.5.2.0" FILE_DESCRIPTION="C++ application development framework." COMPANY_NAME="Nokia Corporation and/or its subsidiary(-ies)" PRODUCT_NAME="Qt4" FILE_VERSION="4.5.2.0" ORIGINAL_FILENAME="qsvg4.dll" LEGAL_COPYRIGHT="Copyright (C) 2009 Nokia Corporation and/or its subsidiary(-ies)" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x804B" LINKER_VERSION="0x10000" UPTO_BIN_FILE_VERSION="4.5.2.0" UPTO_BIN_PRODUCT_VERSION="4.5.2.0" LINK_DATE="06/20/2009 07:59:03" UPTO_LINK_DATE="06/20/2009 07:59:03" /> <MATCHING_FILE NAME="imageformats\qtif4.dll" SIZE="327168" CHECKSUM="0x5E3E2AF7" BIN_FILE_VERSION="4.5.2.0" BIN_PRODUCT_VERSION="4.5.2.0" FILE_DESCRIPTION="C++ application development framework." COMPANY_NAME="Nokia Corporation and/or its subsidiary(-ies)" PRODUCT_NAME="Qt4" FILE_VERSION="4.5.2.0" ORIGINAL_FILENAME="qtiff4.dll" LEGAL_COPYRIGHT="Copyright (C) 2009 Nokia Corporation and/or its subsidiary(-ies)" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x5906C" LINKER_VERSION="0x10000" UPTO_BIN_FILE_VERSION="4.5.2.0" UPTO_BIN_PRODUCT_VERSION="4.5.2.0" LINK_DATE="06/20/2009 07:59:23" UPTO_LINK_DATE="06/20/2009 07:59:23" /> <MATCHING_FILE NAME="plugins\background\MYahooBackgroundPlugin.dll" SIZE="33280" CHECKSUM="0x853808A2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x101F0" LINKER_VERSION="0x10000" LINK_DATE="08/12/2009 08:48:29" UPTO_LINK_DATE="08/12/2009 08:48:29" /> <MATCHING_FILE NAME="plugins\styles\skulpture.dll" SIZE="356864" CHECKSUM="0xE1A5749A" MODULE_TYPE="WIN32" PE_CHECKSUM="0x5BB1B" LINKER_VERSION="0x10000" LINK_DATE="08/12/2009 08:48:44" UPTO_LINK_DATE="08/12/2009 08:48:44" />

</EXE> <EXE NAME="kernel32.dll" FILTER="GRABMI_FILTER_THISFILEONLY">

<MATCHING_FILE NAME="kernel32.dll" SIZE="1063424" CHECKSUM="0x2E7379C2" BIN_FILE_VERSION="5.1.2600.5512" BIN_PRODUCT_VERSION="5.1.2600.5512" PRODUCT_VERSION="5.1.2600.5512" FILE_DESCRIPTION="Client-DLL für Windows NT-Basis-API" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Betriebssystem Microsoft® Windows®" FILE_VERSION="5.1.2600.5512 (xpsp.080413-2111)" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="© Microsoft Corporation. Alle Rechte vorbehalten." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x106523" LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.5512" UPTO_BIN_PRODUCT_VERSION="5.1.2600.5512" LINK_DATE="04/14/2008 02:21:52" UPTO_LINK_DATE="04/14/2008 02:21:52" VER_LANGUAGE="Deutsch (Deutschland) [0x407]" />

</EXE> </DATABASE>

Attachments (2)

4562_appcompat.txt (19.1 KB) - added by delta82 11 years ago.
Crash report
13.01.2010.rar (241.4 KB) - added by delta82 11 years ago.
Can attach it as RAR :-)

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by delta82

Attachment: 4562_appcompat.txt added

Crash report

comment:1 Changed 11 years ago by Chris Browet

By "a file", I assume a .mdc?

Could attach it (zipped) to the ticket, please

comment:2 Changed 11 years ago by delta82

Not possible due to this error:

Internal Server Error 500 Internal Server Error (Maximum attachment size: 262144 bytes)

Currently its zipped (364.176 Bytes). I uploaded to rapidshare: http://rapidshare.com/files/336757001/13.01.2010.zip.html

comment:3 Changed 11 years ago by delta82

The application crashes when the file is loaded on 99%. Maybe that helps too.

Changed 11 years ago by delta82

Attachment: 13.01.2010.rar added

Can attach it as RAR :-)

comment:4 Changed 11 years ago by Chris Browet

Please upload to uploading.com or other service. Rapidshare doesn't let me in.

comment:5 Changed 11 years ago by Chris Browet

Nevermind. Didn't saw your update

comment:6 Changed 11 years ago by deltabrasil

U will get it fixed?

comment:7 Changed 11 years ago by Chris Browet

Owner: changed from cbro@… to Chris Browet
Status: newassigned

I will (hopefully), but I first have to finish the current new feature (GeoTIFF)

comment:8 Changed 11 years ago by deltabrasil

Great. Never mind i uploaded the changes from a backup :-)

comment:9 Changed 11 years ago by Chris Browet

(In [19586]) FIX : Do not crash if undo Index in mdc is wrong (Refs #2644)

comment:10 Changed 11 years ago by Chris Browet

The root cause will be hard to find, but you can at least open the file, now (even if you don't need it anymore...)

comment:11 Changed 11 years ago by Chris Browet

Do you remember if you received error messages during an upload?

comment:12 Changed 10 years ago by Chris Browet

Resolution: fixed
Status: assignedclosed

Crash solved. Root cause to find out...

Note: See TracTickets for help on using tickets.