Ticket #2659 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

100% CPU usage and Crash on creating large traffic circle

Reported by: deltabrasil Owned by: Koying
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

Merkaartor uses 100% CPU and crashes after 1 minute without a warming (it closes).

What i did: I created a large traffic circle (see image) from the feature Merkaartor provide. After approve the creating iut uses 100% of CPU usage and crashes without warning later on.

It doesnt matter if i load a save file or not, it crashes any time.

Attachments

bug2.JPG Download (139.6 KB) - added by deltabrasil 4 years ago.
bug1.JPG Download (132.1 KB) - added by deltabrasil 4 years ago.
Image1.jpg Download (142.5 KB) - added by deltabrasil 4 years ago.
Now i got crash information from the C Runtime at least

Change History

Changed 4 years ago by deltabrasil

Changed 4 years ago by deltabrasil

comment:1 Changed 4 years ago by Koying

I cannot reproduce, not in 0.14 nor in SVN.

What OS do you use? Does it crash also in a new document?

comment:2 Changed 4 years ago by deltabrasil

Try add a large circle on Lat -12.65147 Lon -38.068671. I use Windows XP SP 3 with Version 0.14.

In empty document it doesn't crash but it crashes when i export the data from OSM (I always use the same data and update it all 2 days):

 http://api.openstreetmap.org/api/0.6/map?bbox=-38.537,-13.031,-38.023,-12.563

Try it our yourself to draw a cirle on this position. A really funny stuff.

comment:3 Changed 4 years ago by deltabrasil

0.15SVN doen't crash anymore.

comment:4 Changed 4 years ago by deltabrasil

No still crashes... D'oh!

Changed 4 years ago by deltabrasil

Now i got crash information from the C Runtime at least

comment:5 Changed 4 years ago by Koying

  • Owner changed from cbro@… to Koying
  • Status changed from new to assigned

Yep... Some kind of infinite recursion....

comment:6 Changed 4 years ago by koying

  • Status changed from assigned to closed
  • Resolution set to fixed

(In [19675]) FIX : 100% CPU usage and Crash on creating roundabout (fixes #2659)

Note: See TracTickets for help on using tickets.