Opened 9 years ago

Closed 9 years ago

#2668 closed defect (fixed)

Gosmore cannot be started on WinMobile 6.0

Reported by: stephan75 Owned by: nroets@…
Priority: major Milestone:
Component: gosmore Version:
Keywords: Cc:

Description

On an e-ten Glofiish M800 Smartphone with WinMobile? 6.0 I have no success in starting Gosmore version of 24th Jan. 2010.

After klicking in the file explorer a very firsts beginning of the gosmore screen seems to appear, but then it quits to the desktop.

Deleting gosmore.opt doesn't help, it is even not written now.

Same gosmore version and map-file works fine under WinMobile? 2003 on another PDA.

Is the a possibility to write a log file to see why gosmore is aborting?

Is there any other user who can start the new gosmore versions on WM6?

Change History (9)

comment:1 Changed 9 years ago by nroets@…

Gosmore writes it's log file to \My Documents by default. If you have an opt file on your SD card, it will be on your SD card.

I've upload a new WinMob? binary that is compatible with the old pak file. It's logging is more extensive: Just before executing important lines, their numbers are logged. Post your results here, or use track to look up what the problem is.

comment:2 Changed 9 years ago by stephan75

Thanks for the quick response and the new version of 28th January!

This version still aborts starting, and the log file says: line 3289

Is it low memory, or do i need a fresh download of the map file?

(I'm (still) not familiar with using an SVN-system on my own to examine the source code)

comment:3 Changed 9 years ago by nroets@…

I've made the logging more detailed and update the .exe but not the SVN. Can you try it again ? Please give me at least the last 10 lines.

comment:4 Changed 9 years ago by stephan75

Here we go:


[18:35:27] 2382 [18:35:27] 2399 [18:35:27] 291 [18:35:27] 292 [18:35:27] 293 [18:35:27] 295 [18:35:27] 298 [18:35:27] 308 [18:35:27] 310 [18:35:27] 312 [18:35:28] 313 [18:35:28] 357 [18:35:28] 2400 [18:35:28] 3252 [18:35:28] 3261 [18:35:28] 3262 [18:35:28] 2765 [18:35:28] 2773 [18:35:28] 2778 [18:35:28] 2784 [18:35:28] 2791 [18:35:28] 2792 [18:35:28] 2793 [18:35:28] 2795 [18:35:28] 2798 [18:35:28] 2798 [18:35:28] 2798 [18:35:28] 2801 [18:35:28] 2805 [18:35:29] 3267 [18:35:29] 3289 [18:35:29] 1 49160 0 3 [18:35:29] 1 15 0 0

comment:5 Changed 9 years ago by stephan75

another try:

-----
[18:35:27] 2382
[18:35:27] 2399
[18:35:27] 291
[18:35:27] 292
[18:35:27] 293
[18:35:27] 295
[18:35:27] 298
[18:35:27] 308
[18:35:27] 310
[18:35:27] 312
[18:35:28] 313
[18:35:28] 357
[18:35:28] 2400
[18:35:28] 3252
[18:35:28] 3261
[18:35:28] 3262
[18:35:28] 2765
[18:35:28] 2773
[18:35:28] 2778
[18:35:28] 2784
[18:35:28] 2791
[18:35:28] 2792
[18:35:28] 2793
[18:35:28] 2795
[18:35:28] 2798
[18:35:28] 2798
[18:35:28] 2798
[18:35:28] 2801
[18:35:28] 2805
[18:35:29] 3267
[18:35:29] 3289
[18:35:29] 1 49160 0 3
[18:35:29] 1 15 0 0

comment:6 Changed 9 years ago by nroets@…

We know the problem is in the first WM_PAINT. I expanded the logging. I also changed the font code, because the default font may not be available.

Can you please download and test ?

comment:7 Changed 9 years ago by stephan75

something strange is happening:

when I start the new fresh compiled version, the usual security question of WM6 appears whether I trust the new application to be executed, and then ... tataa ... Gosmore starts and i can use it. then i quit gosmore and the logfile contains many many entries.

Then I restart Gosmore, and the very first outline of the search field appears, and Gosmore quits! So I was only able to start it one time!

The log of the second time (third start is identical) looks like this:

[13:02:33] 2382
[13:02:33] 2399
[13:02:33] 291
[13:02:33] 292
[13:02:33] 293
[13:02:33] 295
[13:02:33] 298
[13:02:33] 308
[13:02:33] 310
[13:02:33] 312
[13:02:34] 313
[13:02:34] 357
[13:02:34] 2400
[13:02:34] 3255
[13:02:34] 3264
[13:02:34] 3265
[13:02:34] 2765
[13:02:34] 2773
[13:02:34] 2778
[13:02:34] 2784
[13:02:34] 2791
[13:02:34] 2792
[13:02:34] 2793
[13:02:34] 2795
[13:02:34] 2798
[13:02:34] 2798
[13:02:34] 2798
[13:02:34] 2801
[13:02:34] 2805
[13:02:34] 3270
[13:02:34] 3292
[13:02:34] 1 49160 0 3
[13:02:34] 1 15 0 0
[13:02:34] 2818
[13:02:34] 2819
[13:02:34] 2820
[13:02:34] 2823
[13:02:34] 2824
[13:02:34] 2825
[13:02:34] 2827
[13:02:34] 2830

comment:8 Changed 9 years ago by nroets@…

Line 2830 is where a lot of pens and brushes were allocated in an inefficient way. I changed it to be more efficient and uploaded it. Please try it.

Running out of resources would explain the "strange" behaviour.

comment:9 Changed 9 years ago by stephan75

Resolution: fixed
Status: newclosed

seems to be fixed with http://trac.openstreetmap.org/changeset/19932

Thanx a lot!

Note: See TracTickets for help on using tickets.