Opened 9 years ago

Closed 6 years ago

#2700 closed defect (wontfix)

Potlatch sometimes leaves unconnected nodes when editing ways

Reported by: NE2 Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

Often making major edits to ways in Potlatch will leave behind random points. Here's how to reproduce (using "edit with save"): *1. Create a new untagged unconnected point by triple clicking (we'll call it point A), save, and close the tab. *2. Start editing again with a new changeset and draw two lines, each connecting a new point with point A. In other words, we now have two lines BA and CA, and point A no longer displays as a green dot. Save and close again. *3. Start a third session. Select line CA, click on point A, hit delete, and then double click elsewhere. Do the same for line BA. *The order matters here; the line created second in step 2 must be edited first in step 3.* In other words, lines CA and BA are now CD and BE, and point A is unconnected (but still not displayed). Save but don't close. *4. Now pan and wait for the data to stop loading. Point A will reappear.

Change History (9)

comment:1 Changed 9 years ago by NE2

For the record, this isn't just an invisible problem - I just saw an unconnected traffic light node get left behind when I redid an intersection.

comment:2 Changed 9 years ago by SK53

Priority: majorminor

I have examined this and indeed the behaviour is as described, but I cannot see that it is a bug. Node A has an independent existence from ways 1 (originally from C->A) and 2 (from B->A). Removing the connection of a way does not remove the associated nodes. Indeed it would be very tedious if one accidentally connected to a node and then undid the connection resulting in the loss of some valuable POI.

At best there is a bug that Potlatch does not immediately redraw the node as a green dot. Accordingly I have downgraded this to minor. It may even be trivial because the workaround is merely to pan away and back.

If you are experiencing this frequently I suggest changing the order of your edits: I only experience this very occasionally, usually when I accidentally connect a highway to a bus stop. In fact your detailed example reassures me that Potlatch does not damage the bus_stop node in this case.

comment:3 Changed 9 years ago by NE2

Priority: minormajor

SK53, do you edit in the US? I do and see this happen often on roads from the TIGER import. Merely deleting a highway, with no other edits, sometimes leaves behind stray nodes (presumably due to a combination of the import and edits prior to my deletion).

One possible solution for your described situation would be to only delete the unconnected node if also it's untagged (as most in fact are). The few that are tagged would certainly benefit from redrawing without panning.

comment:4 Changed 9 years ago by NE2

(By the way, the workaround requires saving and panning.)

comment:5 Changed 9 years ago by NE2

You can see a good example if you edit here: http://www.openstreetmap.org/?lat=27.955192&lon=-82.796358&zoom=18&layers=B000FTF All I did was redraw a portion of the rail line http://www.openstreetmap.org/browse/way/11250356, which formerly contained all the stray nodes (apparently in version 9?). The only edits made to these nodes, for example http://www.openstreetmap.org/browse/node/99962450/history, were by DaveHansenTiger? as part of the import and woodpeck_fixbot to remove unnecessary tags.

comment:6 Changed 9 years ago by ed@…

I have seen these extra nodes appear when doing Tiger cleanup. Two ways are duplicated along a boundary. Some side roads go into one county from one of those ways and some go into the other county from the other. To clean up, delete one of the duplicated ways then select the other and press J to join it to all the side roads. As NE2 says, if you then save and pan, all the newly created orphan nodes (at the junctions with some of the side roads) become visible.

comment:7 Changed 9 years ago by Richard

Thanks, that is helpful.

comment:8 Changed 9 years ago by NE2

I've found that this happens often when cutting a previously-imported way in half and then deleting nodes from the newly-created way (such as when creating and tidying a bridge; here the center of the three ways gets nodes removed by the tidying).

comment:9 Changed 6 years ago by iandees

Resolution: wontfix
Status: newclosed

Cleaning aging tickets.

Note: See TracTickets for help on using tickets.