Opened 9 years ago

Closed 9 years ago

#2738 closed defect (fixed)

gosmore (r20088) fastest-route is making poor decisions

Reported by: David Dean Owned by: David Dean
Priority: major Milestone:
Component: gosmore Version:
Keywords: Cc:

Description

I've recently started using the latest versions of gosmore more than my old r17226 version, but I've noticed that there appears to be some problems with the comparative weights of different road types causing gosmore to make some weird decisions.

These do not appear to be related to turn restrictions, as they are happening at junctions without turn restrictions for the most part.

They do not appear to be related to bad data, as a shortest-route performs properly.

A few examples of where this is happening:

http://imgur.com/hpKAN.png http://imgur.com/W8BEt.png http://imgur.com/tKtXq.png

Change History (9)

comment:1 Changed 9 years ago by David Dean

After, a bit of mucking around I've determined that the bug in http://i.imgur.com/W8BEt.png does not exist in r18055 but does exist in r18177. A bit changed in r18177 tho, so there is a bit of work to track down what the actual error might be.

Some of the other examples appear to be fixed in more recent revisions so we may be dealing with multiple bugs here.

comment:2 Changed 9 years ago by nroets@…

In hpKAN there are two oneway links that I find very odd, considering it is a left hand traffic country.

http://www.openstreetmap.org/?lat=-27.42621&lon=153.01838&zoom=16

Some of these bugs is most likely caused by the feature that avoids crossing a busy road. Considering the number of possible layouts and traffic authorities, this feature may be simply too ambitious in which case it should be disabled.

d += (Style (Way (layoutNd[1]))->invSpeed[motorcarR] <

Style (w)->invSpeed[motorcarR] ? 50000 : 9000) *

...

comment:3 Changed 9 years ago by daviddean

Resolution: fixed
Status: newclosed

(In [20117]) Fixed bug in loading maxspeeds in an attempt to fix #2738. Not quite there yet tho.

comment:4 Changed 9 years ago by David Dean

Resolution: fixed
Status: closedreopened

I found a bug in loading the maxspeeds when they are tagged on a way that set all maxspeeds to 30km/h, and submitted the fixed version as r20117. This appears to fix the problem in http://imgur.com/tKtXq.png, but the other two examples are still not working.

comment:5 Changed 9 years ago by David Dean

http://i.imgur.com/hpKAN.png appears to be related to rhd being set to TRUE when it really should be FALSE in Australia. If I hard code it to FALSE, http://i.imgur.com/hpKAN.png works correctly. I'm still not sure what is causing http://i.imgur.com/W8BEt.png.

comment:6 Changed 9 years ago by David Dean

Owner: changed from nroets@… to David Dean
Status: reopenednew

Isn't rhdBbox actually lhdBbox given that it contains all of the lhd countries?

comment:7 Changed 9 years ago by David Dean

I've fixed the problems with rhd (I hope) in r20118. http://i.imgur.com/hpKAN.png works now.

comment:8 Changed 9 years ago by David Dean

Commenting out the road-crossing section that you suggested makes http://i.imgur.com/W8BEt.png work as expected.

Both of the roads have the same speed, but the 90 metre penalty makes it apparently cheaper to go up the side street an u-turn back.

Perhaps a very-tight/u-turn penalty would make this work better?

comment:9 Changed 9 years ago by daviddean

Resolution: fixed
Status: newclosed

(In [20119]) Commented out road-crossing penalty code for the moment to fix #2738

Note: See TracTickets for help on using tickets.