Opened 9 years ago

Closed 6 years ago

#2743 closed defect (worksforme)

Nominatim doesn't recognize area sizes correctly

Reported by: OSMfan Owned by: geocoding@…
Priority: major Milestone:
Component: nominatim Version:
Keywords: admin_level, area, state Cc:

Description

In Switzerland there is a state which covers (according to Nominatim) about 95% of the whole country (but is actually quite small). I don't know if this is actually a bug of Nominatim, but I couldn't see a possibility to change this just by tagging nodes/relations differently.

The strange thing is that the "state" entry found by Nominatim has the admin_level=100 (placing it at the bottom of the Nominatim's indexing hierarchy) even though it is recognized as a state and should thus be admin_level=4 or (according to Nominatim's development overview) admin_level=8: http://nominatim.openstreetmap.org/details.php?place_id=539508

Nominatim also finds the administrative boundary which is correctly labeled admin_level=4 but does not depict the exclave of this state, which is present in the respective relation: http://nominatim.openstreetmap.org/details.php?place_id=65435320

It would be interesting to know how these two problem arise and how to fix them since there are similar other problems in Switzerland.

Change History (3)

comment:1 Changed 7 years ago by Tom Hughes

Owner: changed from openstreetmap@… to geocoding@…

comment:2 Changed 6 years ago by skyper

Are you still able to reproduce the problem ?

The two provided links lead to objects which do not fit. Could you please update your examples ?

Thanks

comment:3 Changed 6 years ago by Sarah Hoffmann

Resolution: worksforme
Status: newclosed

Probably solved by the reimport of the Nominatim DB and the import of admin boundaries in Switzerland.

Note: See TracTickets for help on using tickets.