Opened 9 years ago

Closed 6 years ago

#2790 closed defect (invalid)

Short summary for reverse geocoding includes a housenumber, but no city at z14

Reported by: amm Owned by: geocoding@…
Priority: minor Milestone:
Component: nominatim Version:
Keywords: Cc:

Description

For the reverse geocoding example of http://nominatim.openstreetmap.org/reverse?lat=49.0942079697809&lon=8.27565898861822&zoom=14&addressdetails=1 nominatim returns "64, 76751, Germersheim, Rheinland-Pfalz, Bundesrepublik Deutschland" I.e. it returns the housenumber, the postcode and the county, but no city or village. The more detailed information has the information correctly.

At zoom 14, not including the city/village seems correct, but it should then also not include the housenumber.

Perhaps the problem is that the postcode node it finds ( http://www.openstreetmap.org/browse/node/307202834 ) also has a housenumber on it.

Change History (3)

comment:1 Changed 9 years ago by osm@…

I don't think zoom makes any difference. But I agree, the city seems to be missing altogether, it was there earlier:

http://nominatim.openstreetmap.org/reverse?format=json&addressdetails=1&lat=52.461224793756&lon=13.302431970084

comment:2 Changed 7 years ago by Tom Hughes

Owner: changed from openstreetmap@… to geocoding@…

comment:3 Changed 6 years ago by Sarah Hoffmann

Resolution: invalid
Status: newclosed

Sounds like a data problem. Gone in the meantime.

Note: See TracTickets for help on using tickets.