Opened 9 years ago

Closed 9 years ago

#2808 closed defect (fixed)

Nearmap TMS no longer visible

Reported by: Travers Carter Owned by: cbro@…
Priority: minor Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

Recently (I think maybe since r20532) the Nearmap TMS no longer renders, some TMSes do still work but the zoom appears to be off (eg OSM Mapnik / Maplint) - the TMS loads and is correctly aligned but very pixellated.

As far as I can see the Nearmap problem is that Merkaartor is calculating the tile co-ordinates incorrectly, I can access the tiles using Nearmap's own website fine and all the tiles have 6 digit x/y but Merkaartor is requesting tiles with 3 digit x/y co-ords for the same area and zoom level.

The problem is evident here: http://www.openstreetmap.org/?lat=-33.80627&lon=151.18091&zoom=17&layers=B000FTF

Merkaartor always seems to be trying to load http://www.nearmap.com/maps/nml=Vert&x=941&y=614&z=20

This is on a 64bit linux build (Fedora 12)

Attachments (2)

merkaartor.log (7.9 KB) - added by Travers Carter 9 years ago.
Log file when trying to enable NearMap? TMS
merkaartor-no-nearmap-tms.png (242.1 KB) - added by Travers Carter 9 years ago.
Screenshot of (missing) NearMap? TMS in Artarmon, NSW, Australia

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by Chris Browet

Are you using latest trunk?

This is normally solved in r20545

comment:2 Changed 9 years ago by Travers Carter

Yes, I just retested with a clean checkout and build of r20595 and the problem is still present.

comment:3 Changed 9 years ago by Chris Browet

Definitely looks right by me.

Could you attach:

  • a screenshot
  • the log

please

Changed 9 years ago by Travers Carter

Attachment: merkaartor.log added

Log file when trying to enable NearMap? TMS

Changed 9 years ago by Travers Carter

Screenshot of (missing) NearMap? TMS in Artarmon, NSW, Australia

comment:4 Changed 9 years ago by Travers Carter

Priority: majorminor

Attached, but I think I've found the problem now ~/.merkaartor/TmsServerList.xml had: minzoom="10" maxzoom="21"

While the svn copy in share/ has: minzoom="0" maxzoom="23"

Changing ~/.merkaartor/TmsServersList.xml to minzoom="0" got things working again.

Experimenting a little further tt appears that the TMS handling (at least for NearMap?) only works when minzoom is set to 0, I'm not sure if that's a bug in itself, but it's easy enough to work around.

comment:5 Changed 9 years ago by Travers Carter

I can replicate the original problem with the svn version of TmsServersList?.xml too by choosing any TMS with a minzoom != 0 (eg OSM Maplint), which doesn't load and then switching back to NearMap?

comment:6 Changed 9 years ago by Chris Browet

Resolution: fixed
Status: newclosed

Solved I think

Note: See TracTickets for help on using tickets.