Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2868 closed defect (invalid)

Accented characters are not entered into Potlatch anymore

Reported by: kenohori@… Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: accents, international, potlatch Cc:

Description

In Potlatch 1.4, entry of accented (áéíóúÁÉÍÓÚ) and other non ASCII characters stopped working.

Change History (6)

comment:1 Changed 9 years ago by Richard

Resolution: worksforme
Status: newclosed

Works fine for me.

Nothing in the text input code has been changed with 10.4: look at the trac changelog if you're unsure. To look at this, I'll need more than one report, and also details of your browser, OS and Flash Player version.

comment:2 Changed 9 years ago by kenohori@…

I spent some time looking into this, and it seems to be a bug in Flash Player 10.1.53.7, not Potlatch. Sorry for the trouble.

comment:3 Changed 9 years ago by Richard

No problem. International input on Flash Player for Linux is famously troublesome.

comment:4 in reply to:  3 Changed 9 years ago by 232 U 1

Resolution: worksforme
Status: closedreopened

Replying to Richard:

No problem. International input on Flash Player for Linux is famously troublesome.

Hello,

There's a residual problem with accented characters with Firefox 3.6.3 / Mac OS X.5 / Flash Player 10.0.45.2 / French keyboard. I can enter some accented characters - namely, those already on the keyboard, such as éèàùç, but I cannot enter â, ê, or ô directly. However, copy/paste works fine. FWIW, the problem doesn't show up with Safari.

comment:5 Changed 9 years ago by Richard

Resolution: invalid
Status: reopenedclosed

Confirmed, but could you please open that as a new ticket mentioning OS X? This ticket is a Linux one. Thanks.

comment:6 Changed 9 years ago by Richard

Actually - don't bother reopening it: I think this is a Firefox/FP issue rather than a Potlatch one. I've just tried with a random Flash app found on the web (http://www.tizag.com/pics/flash/form1easy.swf) and it exhibits exactly the same behaviour. We probably need to wait for Mozilla, Adobe or Apple to fix it, I'm afraid.

Note: See TracTickets for help on using tickets.