Opened 5 years ago

Closed 12 months ago

#2871 closed defect (worksforme)

Cities in Australia report as postal code

Reported by: mike@… Owned by: geocoding@…
Priority: major Milestone:
Component: nominatim Version:
Keywords: Australia city Cc: Rudi, Heitbaum

Description

performing a reverse geocode look up in Australia will return the postcode in the city

Example:

http://nominatim.openstreetmap.org/reverse?format=json&lat=-33.906895553&lon=150.99609375
returns
{"place_id":27288266,"licence":"Data Copyright OpenStreetMap Contributors, Some Rights Reserved. CC-BY-SA 2.0.","osm_type":"way","osm_id":23649580,"display_name":"Quentin Street, Bass Hill, 2197, New South Wales, Australia","address":{"road":"Quentin Street","suburb":"Bass Hill","city":2197,"postcode":2197,"state":"New South Wales","country":"Australia","country_code":"au"}}

Change History (3)

comment:1 Changed 4 years ago by Rudi Heitbaum

  • Cc Rudi Heitbaum added

From what I can see. The issue is that the Administrative Region level is set to 8 for the Postcode. Level 10 for the Suburb. See the following way for an example: http://www.openstreetmap.org/browse/way/32289977. In Australia a correct postal address is:

12 Smith Street # ROAD

New Farm # Suburb

Queensland 4005 # State # Postcode

Australia # Country

as Per: http://auspost.com.au/personal/addressing-guidelines.html / http://en.wikipedia.org/wiki/Address_%28geography%29

So by my reckoning; we should be returning :

<road>Alford Street</road> # AS-IS

<suburb>New Farm</suburb> # Level 10

<postcode>4005</postcode> # Level 8

<state>Queensland</state> # AS-IS

<country>Australia</country> # AS-IS

<country_code>au</country_code> #AS-IS

Hamlets/Towns? should be ignored. (maybe even villages.)


In this case the data is a better representation:
http://nominatim.openstreetmap.org/reverse?format=xml&lat=-37.793352&lon=144.930026&zoom=18&addressdetails=1

In the above example;

<restaurant>Thai By Night</restaurant> # VALID

<road>Wight Street</road> # VALID

<suburb>Kensington</suburb> # VALID

<town>Footscray</town> # INVALID

<city>3031</city> # Same as postcode - Assume postcode is coming from the Node

<county>City of Melbourne</county> # VALID - This is known as a Council in Australia

<postcode>3031</postcode> #VALID

<state>Victoria</state> #VALID

<country>Australia</country> #VALID

<country_code>au</country_code> #VALID

comment:2 Changed 3 years ago by TomH

  • Owner changed from openstreetmap@… to geocoding@…

comment:3 Changed 12 months ago by lonvia

  • Resolution set to worksforme
  • Status changed from new to closed

Looks okay these days, please reopen if the issue should appear again.

Note: See TracTickets for help on using tickets.